Alfa Romeo Forum banner

1 - 20 of 125 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Hi All
Robert from a snowy Sweden here..
today i got hooked up again up the Alfa virus and bought a 1998 156 2.0 TS
the car was very cheap.. because it doesnt start..!!:cheese:
i havent done anything yet.. but the former owner was away 6 weeks on vacation these summer and after returning the battery was dead and the car had never started since then..
any idea what to look after?
can it bee the key ? i have only one but i also have the paper tag with the key codes..
maybe the imobilizer?
please fell free the share your thoughts.. so i have something to go after..
thanks for all your help..!

cheers
Robert
 

·
Registered
Joined
·
1,925 Posts
Crank sensor is a possibility. If the immobiliser is at fault there should be some indication on the dash.

Check fuel is getting into the cylinders (are the plugs getting wet with pertrol), are the lugs sparking?

Is it making any effort at all to start, any spluttering?

All the best

Pub
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
Hi Pub!
i just came with the car on a trailer,, so ill ike to get so much info for tomorrow when im going into it..
as far the former owner told me.. all the electronics, windows etc works.. the engine cranks,, but no life whatsoever..i dont know anything about the codes on the dashborad.. im at the moment charging the battery so its 100% for tomorrow..
the cam belt was change 2 years ago and he also have take a compression test on all 4 cylinders.. and there where ok..
 
L

·
Guest
Joined
·
0 Posts
try pressing the fuel reset button located under the passengers seat, 1st make sure it has > 1/4 tank of fuel.

re imobiliser issue: look at the screen betweent he speedo & rev counter, if the yellow coloured key shaped symbol is always illuminated then the immobiliser is active & the car won't start. if you have the Electronic Code [ on the credit card ] then follow the emergency starting procedure in the owners manual. if the car starts then you need to check the fuse required or the antenna .
 
L

·
Guest
Joined
·
0 Posts
Crank sensor danaged during belt change
crank sensor is at the gear box side of engine, cam sensor is at the the timing belt of enigne [ opposite end ], how could they damage the crank sensor? :cheese:
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
Ok..
now i have tested to run.. no luck..
all the electrics i have seen so far works..
when i turn the ignition key the yellow key blinks for half a second or so as all the rest of the
instruments does..
the engine cranks as usual.. but no ignition at all.. not even a missfire..
i have tryed to push the rubber cover button under the left seat.. is that the fuel reset button?
no change..
any idea what can be the fault?
thank you so much for your help..
Robert
 

·
Registered
Joined
·
2,518 Posts
Mine was the Crank Sensor.

It was driving along ok on the motorway and then I parked up at the services. Started ok but then only went about a mile before it cut out. Operating the key just cranked the engine with no life at all.
 

·
Registered
Joined
·
195 Posts
Mine was the Crank Sensor.

It was driving along ok on the motorway and then I parked up at the services. Started ok but then only went about a mile before it cut out. Operating the key just cranked the engine with no life at all.
+1 on the crank sensor.

From memory about £18 and 10 minutes to fit. 1 bolt and 1 electrical connector on the back of the engine (between the engine and firewall).

If it turns out not to be that, then you have a spare for when it does go - eventually.
 

·
Registered
Joined
·
5,266 Posts
Get the fault codes read before you go randomly changing parts. Crank sensors don't often give the symptoms your car has so I'd be inclined to say thats not the problem.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #13
do i need a special reader for finding the fault code?
some cars can display the fault code and i dont knwo if The Alfa does that..
 

·
Registered
Joined
·
11,604 Posts
Get a USB KKL cable off eBay and download FiatECUScan :thumbs:
 

·
Registered
Joined
·
11,604 Posts
That'll do ya :thumbs: - cable won't connect to airbags or ABS systems without modification, but will serve its purpose for what you need it for now.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #19
about the engine.. wrote several threads that it seems important that there quite much petrol in the tank?
why is that?
on all cars i owned you can virtually run it untill the last drop of it..

cheers
Robert
 
1 - 20 of 125 Posts
Top