Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I see a number of previous posts about this problem. However before I looked at the forum I spend the afternoon trying to fathom out why boot wouldn't close. Lots of slamming since I felt it must be mechanical after taking catch out etc. When the latch is in closed position it opens on the button in the glovebox and also by key in the boot. I've tried manually locking and unlocking as well as using the remote. Now it's dark I'll wait 'till tomorrow to follow forum advice about solenoids etc behind spare wheel in boot. Any recent advice/experience from amyone out there is welcome though because I want to sort this out.
My recent Autolusso oil cooler kit has worked great ; great service too from them. After the boot it will be sunroof fix time. It opens manually only but closes OK with switch.
 

·
Registered
Joined
·
4,627 Posts
The lock mechanism may need adjustment.

Remove the carpeting covering the rear lights and you'll find a couple of bolts that, when slackened, will allow you to adjust the position of the lock. You probably need to move it up a bit so the latch properly enters the lock. Years of slamming have probably shifted the mechanism down.

Also, at the edges you'll notice two rubber stops, these can be rotated to adjust the boot lid to be flush with the rear wings. As you're adjusting the lock, you may as well perfect the boot lid fit at the same time ( if it needs doing ).
 
1 - 2 of 2 Posts
Top