Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,429 Posts
Discussion Starter #1
when coming off a round about there seems to be a lack of low down boost, sluggishness. once it's up to speed it drives normally when you put your foot down.
also when sat idling, you hit the throttle and the boost needle doesn't shoot up until you're revving it quite high.
i've had the egr mapped out and i know it's not doing a dpf regen.
garage has been over the boost pipes and checked they're all ok.
it put the check engine light on. garage said that said boost.
 

·
Registered
Joined
·
2,429 Posts
Discussion Starter #3
It's been sat in pieces for seven weeks. Can you clean the vanes without taking the bloody thing apart again?
 

·
Premium Member
Joined
·
1,391 Posts

·
Registered
Joined
·
2,429 Posts
Discussion Starter #5
Cheers, ordered some.
You got a scanner to turn the check engine light off? If not I'll go back and see Mark.
 

·
Premium Member
Joined
·
1,391 Posts
You could also check the boost solenoid and attached pipes for crud that might have dried out and partially solidified while its been standing.
 

·
Registered
Joined
·
2,429 Posts
Discussion Starter #8
changed the boost control valve thingy above the radiator today.
took it for a blast, still no change.
 

·
Registered
Joined
·
2,368 Posts
Did you check vac pipes?

You need to check it out with a vac tester to see what the pump is producing and also use it to actuate the turbo vnt mechanism to see if moves it’s full travel freely and maintains a vac without it leaking off.
 

·
Registered
Joined
·
2,429 Posts
Discussion Starter #10
no i've not tested the pipes. what's a vac tester and are they cheap and easy to use.
 
1 - 10 of 10 Posts
Top