Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I recently got my Mito and have a few issues with the Blue & Me, but my suspicions in reading other threads are that they should be solved with a firmware update. Following the instructions to update the firmware fail for me, but I wonder if that's because it was all ready up to date before I bought it. So...

1, is there a menu option somewhere to find out what the current firmware version is? There are threads for other Alfa models about how to acces a 'secret' menu for such things as this, but can't find one for the Mito.

2, would trying to update the firmware when you all ready have the latest give a particular error code? Or does the lovely lady just tell me that it doesn't require updating perhaps?

Cheers,
Mister G
 

·
Registered
Joined
·
320 Posts
I recently got my Mito and have a few issues with the Blue & Me, but my suspicions in reading other threads are that they should be solved with a firmware update. Following the instructions to update the firmware fail for me, but I wonder if that's because it was all ready up to date before I bought it. So...

1, is there a menu option somewhere to find out what the current firmware version is? There are threads for other Alfa models about how to acces a 'secret' menu for such things as this, but can't find one for the Mito.

2, would trying to update the firmware when you all ready have the latest give a particular error code? Or does the lovely lady just tell me that it doesn't require updating perhaps?

Cheers,
Mister G
I updated the B&Me to 5.5 a couple of days ago.
Had a bit of trouble doing it.
Involved disconnecting the battery. 30 seconds should do it. Use the negative terminal - it's a quick release one and comes off without having to use a 'spanner'.
Use a 'small' sized USB 'stick'. I used a 1meg one that came with a Sony Blu ray player doing a full format on the disc before you transfer the software over.
When the update starts leave it for a 'good while' - it took about 10-15 minutes for it to complete.
If it's not going to work it comes up with an Error message in about 1-2 minutes.
I had to upgrade because the 'old' B&Me version would not work with the iphone 3GS.
Re knowing what version is already installed there's no way that a 'punter' can tell from going through the Menu, etc. If might be possible through FiatECU'Scan' but I haven't tried it.
 
1 - 3 of 3 Posts
Top