Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
861 Posts
Discussion Starter #1
Hi guys.

Well, I do not know where to start. Lets start by saying I have a 2008 Fiat Bravo Tjet sport (right hand drive, I am in South Africa) equipped with the blue and me system. My vehicle is rather full house including climate control and panoramic sunroof. The Blue and system is the only thing irritating me to death and actually I am thinking of selling the car because I am fed now with it.

Ever since I bought the car ( from a private seller) the Blue and me system did not work. I will also add that the steering control buttons do not work either. Well, the windows logo and telephone are the only two buttons not working. all the other buttons function well and like they are suppose to.

Now, I have searched the net and browsed other forums and it seems like this is a common problem. I have done basically everything they have said.
Here is a summary of what I have tried to get it working:

1) I removed the negative battery terminal for 10 minutes. attached it again, still not working.
2) I removed the negative terminal for half an hour, still not working.
3) I removed the negative terminal over night, still not working.
4) I formatted a 4GB memory stick to FAT32, downloaded the blue and me update for my car model being a model before 2010, copied the files to my memory stick (not in a folder), inserted the memory stick into the USB port, nothing happens after 10 minutes of waiting. The memory stick lights do flash and the light behind the USB port is on so it tells me there is power to the USB port.
5) I then connected via multiecuscan to the dashboard section of m car, to connect to the blue an me system to check for errors. It then showed no errors.
6) I then did a proxy alignment with multiecuscan. Everything went smooth and it finished within 5 minutes with no problems or errors.
7) tried pressing the windows button on the steering wheel again, nothing happens.
8) I check each and every fuse under the passenger compartment dashboard. They are all fine.
9) I checked each and every fuse in the engine bay, they are also perfect and in order.

TO mention, I have no flashing odometer as I understand that if this happens it might be related in some or other way. I can however add that the only time the KM reading odometer flashes is when I press the trip button on the wiper stalk. that when you go through the different trip meters etc. It flashes while I do that but once I have run through the whole menu and it returns to the normal position the flashing stops. So I am under the impression this is normal when the trip button is pressed on the wiper stalk.

This system is just dead. I really do not know what do do next or what the problem should be. Please I am really stuck now and do not know what to do as I would really like to get this system going again.
The only close part of this Fiat Blue and me system I have ever seen is the blue and me logo on the speedo menu cluster upon start up.

Any ideas or where I should start looking for problems now?
Where is the blue and me system unit located in the Bravo?
Could the unit be faulty or dead because that is the only thing that I think is causing the problem.

any assistance will be highly appreciated.
Thank you for taking the time to read my topic.

Regards
Walter
 

·
Registered
Joined
·
92 Posts
I know how you feel getting no response. Cant really help you too much I'm afraid. However I might throw some ideas at you to prompt more thoughts from you.

Without knowing what buttons you have, I gather the radio volume works up and down and src ok. Have you thought it might be the bluetooth controller not being able to connect to whatever device you have.

My cureent issues are trying to hook up a Blu&Me to a chinese dvd and I have three wires coming back to the radio from the bluetooth, AAFL, AAFR and Gnd. These carry the two channels sound back from the bluetooth receiver tot he radio so I can hear the phone or whatever is paired.

Are all the connections right. If you look on this forum you will see lots of possible different wiring for different radio units. particularly when blue and me is involved. Have you checked the diagram on the radio to make sure the blue and me wiring is connected as a different HU could actually disconnect the wiring. On my car with no radio Windows button works and multifunction display works but no sound and just gives me errors when I try to do anything.


Just some thoughts!
 
1 - 4 of 4 Posts
Top