Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
my 1999 2.0ts gtv is blowing cold air not hot, changed the thermostate on it but still blowing cold air? is it the climate control computer or anything to do with the matrix???
 

·
Registered
Joined
·
13 Posts
There will be a valve that diverts engine coolant into the heater matrix. It's not opening. not sure where it is without the manual on hand. On german cars they are designed to fail open so you dont freeze. Fortunatly its one of the few things on the spider that works...
Number 2 on the picture is the cable that opens the valve on the heater matrix, I think..
 

Attachments

·
Registered
Joined
·
17 Posts
The other possibility (sorry if it's "teaching Granny to suck Eggs") is that when replacing the thermostat, the sytem has not been bled of air completely and that's stopping the flow of water getting through the matrix.
Or blocked matrix...
 

·
Registered
Joined
·
1,590 Posts
Passenger side if it's a right hand drive car. It's operated by cable but normally when it fails it leaks coolant onto the carpet.
 

·
Registered
Joined
·
4,627 Posts
There will be a valve that diverts engine coolant into the heater matrix. It's not opening. not sure where it is without the manual on hand. On german cars they are designed to fail open so you dont freeze. Fortunatly its one of the few things on the spider that works...
Number 2 on the picture is the cable that opens the valve on the heater matrix, I think..
Only on phase 1s. Phase 2 & 3 don't have that valve - the heater matrix has a constant flow of coolant running through it. There is a motorised flap that allows all, some or none of the air to flow through the matrix into the distribution ducts.

The OP's car is 1999 which should be phase 2.
 
1 - 7 of 7 Posts
Top