Alfa Romeo Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
544 Posts
Discussion Starter #1
Is it generally rubbish on a 156?
 

·
Registered
Joined
·
1,589 Posts
nah the aircon is okay on a 156. if you go somewhere like quikfit they do a re-gas or no charge type thing. meaning if you got a leak and they can't regas they won't charge you.

Any aircon regas will consist of the machine vacuuming out the current content and then replacing.

If on vacuuming out the system it does not hold the vacuum the machine will throw a wobbler and refuse to regas it as it won't hold the pressure. not disposing of the refrigerant gas properly is illegal its proper nasty stuff so if the machine suspects anything it won't go - so you will know quite quickly if you have a leak - the acid test is find the leak.

common spot for a leak, if its not in one of the rubber hoses, are the two metal pipes that turn 90 degree left underneath the battery tray across the front of the bulkhead, they sometimes rub on the elbow in the pipe.
 

·
Registered
Joined
·
40 Posts
Been having fun with my aircon. Holds pressure but has a fluctuation on return. Aircon bloke thinks it's: a) a blockage or b) the valve on the bulkhead. Worst case evaporator! By the time I can afford to sort it it's gonna be winter!!
 

·
Registered
Joined
·
55 Posts
Had my aircon regassed 2 summers ago with MOT at kwik **** , was cold for a good 2 hours after I left garage. So paid. the next day no cold air, presumed a leak, a year later got an air con specialist out to diagnose, he couldnt find a leak, so put half charge in and told me to watch for 2 weeks FOC. 2 weeks later, still blowing freezing, so he vacumed the system and fully charged, been spot on for another year! !!!!!!!!!!! Still freezing cold, avoid kwik fit, lesson learned.
 

·
Registered
Joined
·
544 Posts
Discussion Starter #8
hmm, its cold at the vent, on the passenger side, but warmer on my side. At the middle right hand vent its just normal air, slightly cool. Over 25 degeees outside its useless, i do an air exchange instead by opening all the windows..

put it this way, in the heatwave i didnt get out colder than i went in, ever. missus 147 is cold in minutes.
 

·
Registered
Joined
·
4,293 Posts
I am in a similar position, and was told to do the following check by a specialist before bringing it in.

1) Turn the air con off with the button.
2) Turn the dial to cold
3) Put the fan on
4) Check the temperature of the air coming out. If it is "ambient", then the aircon is likely to be inefficient: regas or get it checked out. If it is "hot", then you have a flap problem not an aircon problem - the air con (when swtiched on) is trying to cool the heated air and failing dismally.

After this check, I know mine has an aircon problem and it is booked in....
 

·
Registered
Joined
·
2,525 Posts
Kwik fit might have the same machines but they dont use them properly. They don't check for leaks, they dont vacuum long enough and most times they dont know the amount of gas to put in
 

·
Registered
Joined
·
1,375 Posts
hmm, its cold at the vent, on the passenger side, but warmer on my side. At the middle right hand vent its just normal air, slightly cool. Over 25 degeees outside its useless, i do an air exchange instead by opening all the windows..

put it this way, in the heatwave i didnt get out colder than i went in, ever. missus 147 is cold in minutes.
i'm pretty sure if you unplug battery for 30 mins and plug back in again when you switch the car on again it will attempt to reset the flaps, as it sounds like that might be at least part of the issue

[email protected]
 

·
Registered
Joined
·
2,116 Posts
Should run really nice and cold, about 13-14 degrees, make sure the car air is switched to re-circulation and if you do dis-connect the battery remember where you put your radio code.
 
S

·
Guest
Joined
·
0 Posts
hmm, its cold at the vent, on the passenger side, but warmer on my side. At the middle right hand vent its just normal air, slightly cool. Over 25 degeees outside its useless, i do an air exchange instead by opening all the windows..

put it this way, in the heatwave i didnt get out colder than i went in, ever. missus 147 is cold in minutes.
Either the control flaps are not working, assuming dual zone climate control, or the AC needs regarding. The pipes to the evaporator in the dash come in at the side, when the car is low on gas, that side gets coldish but the side away from the connection pipes won't as the gas evaporates as it passes the pressure reduction valve on the way into the evaporator.




Sent from AutoGuide.com Free App
 
S

·
Guest
Joined
·
0 Posts
i'm pretty sure if you unplug battery for 30 mins and plug back in again when you switch the car on again it will attempt to reset the flaps, as it sounds like that might be at least part of the issue

[email protected]
The battery doesn't need disconnecting for that long. I has some AC control issues with my 156 which meant the control unit needed connecting and disconnecting several times. As soon as the power to the controls is removed and restored it resets itself. Takes a few seconds.

If you don't have the radio code, you can get to the connector plug on the back by removing the radio, leaving it dangling on its wires and unplugging the control unit multiplig.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
544 Posts
Discussion Starter #15
I know the battery code off by heart... yes my car has been that bad in 2012, id have to diconnect the battery every journey... and now my ecu is corrupt (checksum error)

Back tot opic, ill try a reset if not im guessing the gas is just low if its not very cold on my side but it is cold on my missus side ;)
 
S

·
Guest
Joined
·
0 Posts
I know the battery code off by heart... yes my car has been that bad in 2012, id have to diconnect the battery every journey... and now my ecu is corrupt (checksum error)

Back tot opic, ill try a reset if not im guessing the gas is just low if its not very cold on my side but it is cold on my missus side ;)
Yep, I reckon gas is low.

It's a left hand drive basic design, so will be designed to benefit the left hand seat most.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
544 Posts
Discussion Starter #17
booked. £35 in MK mobile mechanic.
 

·
Registered
Joined
·
544 Posts
Discussion Starter #18
regassed today. yep, its running ice now :)
the airflow is a bit crap, the aircon man said it wasnt kicking out very high and told me to look for filters.... any idea where they are?
 

·
Registered
Joined
·
1,375 Posts
in the passenger footwell, behind the glove box. it's a pretty irritating job for something which should b a lot easier as you have to be kinda on your back in the footwell. takes about 30 minutes. do a search for "change pollen filter" or similar

[email protected]
 

·
Registered
Joined
·
544 Posts
Discussion Starter #20
when is it ever a nice job on these buggers!! haha.
thanks, ill take a look!
I dont suffer from hayfever.. ar epollen filters necessary at all?
 
1 - 20 of 22 Posts
Top