Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
11,159 Posts
Discussion Starter #1
Hi anyone , got in car for work this mornin, all ok, started up all ok drove 1/4 mile up road battery alarm warning comes on, stays on until reach destination 10 miles away. check handbook - battery not charging !
got back from work lift popped bonnet and found alternator belt all secure and in place, so looks like alternator has died an early death!
anyone had one changed under warranty?
or otherwise? how much ?
gonna call AlfaCare peeps tomorrow and book in for check up and try get it done under warranty ( it is covered) but how long will it take them to get it sorted?
 

·
Registered
Joined
·
813 Posts
The alternator may be fine. Could be that the battery is duff and isn't retaining its charge anymore..... There is a similar thread on battery lifes. How old is the car and is it still on original battery?
 

·
Registered
Joined
·
238 Posts
The alternator may be fine. Could be that the battery is duff and isn't retaining its charge anymore..... There is a similar thread on battery lifes. How old is the car and is it still on original battery?
The light is for the alternator charging circuit and is usually signalled directly from the alternator, therefore I doubt a slightly duff battery would cause it.

The other possibility is that there is a large fuse between the alternator and the battery. This may have blown (or more probably expired through age/rust). I haven't got the handbook to hand to check.

Ian A.
 

·
Registered
Joined
·
11,159 Posts
Discussion Starter #4
The light is for the alternator charging circuit and is usually signalled directly from the alternator, therefore I doubt a slightly duff battery would cause it.

The other possibility is that there is a large fuse between the alternator and the battery. This may have blown (or more probably expired through age/rust). I haven't got the handbook to hand to check.

Ian A.
Had new battery last year, belt good, battery charged off car last night ok, so doubt that will be cause, got LC Motors in Newport looking at it and they suspect alternator is duff, luckily under warranty. new one on order.
 
N

·
Guest
Joined
·
0 Posts
Duff battery would flag all sorts of other errors.

My money is on the alternator.
 

·
Registered
Joined
·
11,159 Posts
Discussion Starter #6
Duff battery would flag all sorts of other errors.

My money is on the alternator.
yeah me too I only got errors when driving to garage as the battery power dropped I lost ABS, VDC,ASR,radio, heaters, aircon, wipers went really slow and almost stalled twice! luckily got there in time but then could not get key out as not enough juice to enable engine shutdown!! had to stall to get key out of dash!
all cables were good belt good just waiting for new unit now. :thumbs:
 

·
Registered
Joined
·
161 Posts
I've just had this happen to me as well. Battery symbol does not come on immediately, but after a couple of minutes. Engine cranked fine, so there must be reasonable charge in the battery at present. Again suspect alternator, but it is late now and can't find my multimeter. Wondering if I have enough juice to make it to the garage.
 

·
Registered
Joined
·
11,159 Posts
Discussion Starter #8
I've just had this happen to me as well. Battery symbol does not come on immediately, but after a couple of minutes. Engine cranked fine, so there must be reasonable charge in the battery at present. Again suspect alternator, but it is late now and can't find my multimeter. Wondering if I have enough juice to make it to the garage.
I managed to drive about 15 miles on a part charged battery and nearly 50 on a fully charged , the radio is first to go then ABS, VSR, AVC ? or whatever then finally the speedo and rev counter will stop responding and will stick in one place, then when you stop you may not be able to get the key out and may have to stall car to turn off engine ! by this point your battery is lower than a snakes belly! good luck.
 

·
Registered
Joined
·
161 Posts
Managed to get to garage, turned off all non essentials like radio and heating. It was the alternator, so that was £300 including fitting!!!!!!!!
 

·
Registered
Joined
·
11,159 Posts
Discussion Starter #10
Managed to get to garage, turned off all non essentials like radio and heating. It was the alternator, so that was £300 including fitting!!!!!!!!
no warranty then? the wrong time of year for that size of bill ! at least it's sorted out.:thumbs:
 

·
Registered
Joined
·
11,159 Posts
Discussion Starter #12
IN two years of ownership this car has cost me thousands in repairs
I have had a new steering rack ( leaking oil and bad wear) new gearbox (bearing rattling in 5th and 6th, bad noise in all gears, whine in 3rd 4th) new Clutch master cylinder (worn shaft and thread) new alternator ( failed totally) has cost me about £800 for 2 yrs Alfa Care 4th and 5th yr Warranty Cover, but has probably saved me twice that! haven't renewed this year yet but will be doing it in Jan.
FYI £369 for Driveline Cover £469 for Standard Cover and £499 for Premier.
Worth asking about it but beware some dealers will ask for an "inspection" of your car before accepting you and this can cost 1 hours labour or £114 in my nearest Alfa Stealer.
:thumbs:
i recommend it but you may think it's a bit too late for yours? hope this reamble helps in some way!:thumbs:
 
1 - 14 of 14 Posts
Top