Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Having an issue today with my 147 1.6 tspark, I was leaving the car park and driving out onto the main road when my window wouldn't go up any further. Petrol station ahead, changed lanes and when acceleration nothing happened, it felt like it hesitate and lost power. Pulled in anyway, got all sorts of warning beeps, abs ebd failure etc. Shut her off and dead as could be dash hardly lit up.

Called recovery, 30 - 40 mins later he fit there, jumped it and no problem starting, revving etc. Battery charge was a little less than he expected with the engine running. He tested the battery and basically it was foobarred, battery was only 9 months old. All seemed ok again and he thought I'd be ok to drive home.

20 mins or so the same thing started to happen, car because slightly hesitant to accelerate and shortly after I got the error messages again. Could still rev when I pulled in, clocks froze though with the revs at 2k before dying on my.

Brand new battery fitted from the recovery guy to get me home, he tested this and charging seemed normal at 13 volts I think. Drove to halfords the get a replacement battery (15 20 min drive) and then to a friends house (prob another 20 to 30 mins) when it felt like it started to hesitate again. Not wanting to damage the battery the recovery guy lend me I swapped out the halfords one.

I should get home tomorrow if the battery holds up for 30 mins or so but clearly there's something wrong. It seems I won't get any mechanics this side of the weekend but anyone read anything familiar that could point to something being wrong?
 

·
Registered
Joined
·
158 Posts
If you get the engine running and have a multimeter then measure the battery voltage at about 2000rpm, hopefully you should be seeing around 13.5 to 14V on the meter, if less than that the alternator is not putting out enough voltage to keep the battery charged up.

Hope that helps.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Tried a new battery and same thing just happened, lost power, warnings on dash etc and dead now. Shouldn't happen with a new battery, just be the alternator.

Do I need a new one or can they be refurbished? Is replacement do able with basic tools? It looks like it's fairly buried down the side of the engine.

This being a cheap car, is it even worth doing? My timing is due within the next 10k, the variator is getting increasingly more noisy on start up and I'll probably need to replace the wishbones on both sides as they are creaking over bumps and uneven road surfaces.
 

·
Registered
Joined
·
2,783 Posts
ts alternators are a pita and expensive to change. a refurbished one should be all OK. you should check if all cables are all well tight.
 

·
Registered
Joined
·
1,466 Posts
If the alternator is faulty shouldn't you be getting a Charge fault warning light on the dash long before problems start ?. Is the battery really flat after the car conks out, i.e. have you measured the voltage at the posts ? Just because the car appears to have no power doesn't mean the battery is dead, might just be poor connections somewhere as others have said. You can even have a poor connection at the battery post that causes massive voltage drop even though the clamp is tight. Think this needs double checking before condemning the alternator, especially if there's no Charge fault light on the dash.
 

·
Registered
Joined
·
2,783 Posts
or some electric component is draining the battery, stereo head unit, interior lights, anti-theft device, something...
 

·
Registered
Joined
·
2,783 Posts
sorry, read completely your first post, looks like the battery is discharging while engine is running. like others said, bad alternator or bad alternator/battery connections... strange you don't have the charge warning light.
 

·
Registered
Joined
·
8,786 Posts
depends on the failure if the light's on or not. if one of the three phases still works in the alternator, I bet the light stays out. won't be enough to keep the car going though...
 
1 - 11 of 11 Posts
Top