Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
My battery died in the frost, so new battery fitted but I know have the battery light on.

On old car the battery light wire was the power feed for the alternator, is it the same on these, or if the new battery charge was low that put the light on.

My suspision is that my partner has been driving round with the battery light on for a week but its denied, there are no error codes.
 

·
Premium Member
Joined
·
19,119 Posts
If the battery light is on then the alternator is not charging the battery. This is why yor old battery failed. Once the alternator stops charging you might get an hours driving out of the car. Bit more if its a diesel but the alternator is at fault. If you aren't convinced then put a multimeter over the battery terminals while the car is running. Should ready around 14v if the alternator is charging correctly. Oh and you can't blame your other half for driving around for weeks ;) :lol:
 

·
Registered
Joined
·
322 Posts
Discussion Starter #3
Has a severe case of DLRD (dash light recognition disorder).

Last year, "the headlights seem a bit dim" - thats what the big orange light on the dash means they dont work!!!

Its been the same with the brake light, ABS, Air Bags.....
 

·
Premium Member
Joined
·
19,119 Posts
Nope. Only side lights, numberplate lights, tail and brake lights are on the bulb out warning lamp. Not main and dipped beam. :)
 
1 - 4 of 4 Posts
Top