Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #1
Hi, Ive got a 1.9jtd Gt which will not start. To cut to the chase the main fuel pump will not work, we have tried another pump. We have tried a fuel rail engine ecu kit and fuse box. The fuel cut off switch is fine as are all the earths. It has diesel in it and diag says pump not working. What have I missed.:depressed:
 

·
Registered
Joined
·
147 Posts
Discussion Starter #5
Fuel cut off switch changed and both fuse boxes swapped/changed with relays! We swapped another engine ecu and body computer with fuse box from another gt with the correct key.Either the replacement pump is faulty or im missing something. We have checked the loom. Ive had gt in with a misfire but can a wayward injector tell the ecu to stop the pump? any other suggestions are welcome.
 

·
Registered
Joined
·
175 Posts
my 20v broke down the other day. got it owed back to my house where i spent a few hours diagnosing the same issue you have.
the pump in the fuel tank wasnt pumping fuel up to the high pressure pump. after stripping and cleaning almost everything on the fuel system it turned out to be a dodgy connection on the fuel pump relay which is located under the intake pipe just where it goes into the throttle body/intake manifold. cleaned it al up/tested the relay and off she went purring like a kitten again.

hope this helps
 

·
Registered
Joined
·
8,786 Posts
Fuel cut off switch changed and both fuse boxes swapped/changed with relays! We swapped another engine ecu and body computer with fuse box from another gt with the correct key.Either the replacement pump is faulty or im missing something. We have checked the loom. Ive had gt in with a misfire but can a wayward injector tell the ecu to stop the pump? any other suggestions are welcome.
put a light bulb in place of the pump. easiest possible check.

the pump stops if the engine is not turning over, do you get an rpm reading?
 
1 - 7 of 7 Posts
Top