Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
617 Posts
Discussion Starter #1
Hello all!

So I got a code on diagnostics,

Well more than one!! :biglaugh:

Anyway my Head Light Washer jets don't work.

The Screen ones do front and rear.

The code - B1018 Headlamp Washer Relay

Does anyone know please where i can physically locate this relay on the car?

Is it within the fusebox under the bonnet or under the steering wheel or somewhere completely different please?

Thanks for any suggestions!

Also - is there a fuse that I could check before this that might be an easier fix?...

:glasses:
 

·
Premium Member
Joined
·
7,522 Posts
description:
Functional description
The relay T17 for the engine compartment control unit B1 is supplied by the line for fuse F9 for the engine compartment control unit B1 and is energized by the line 'controlled by the ignition' (INT/A) from fuse 31 of the underdashboard control unit B2 .

The relay operates the headlamp washer pump N25 directly when the command arrives from the Body Computer M1 .

The Body Computer, in turn, processes the signal, at pin 14 of connector A, coming from the steering column switch unit H5 and the go ahead with the main beam or dipped headlamps on.
 

Attachments

·
Registered
Joined
·
617 Posts
Discussion Starter #3
description:
Functional description
The relay T17 for the engine compartment control unit B1 is supplied by the line for fuse F9 for the engine compartment control unit B1 and is energized by the line 'controlled by the ignition' (INT/A) from fuse 31 of the underdashboard control unit B2 .

The relay operates the headlamp washer pump N25 directly when the command arrives from the Body Computer M1 .

The Body Computer, in turn, processes the signal, at pin 14 of connector A, coming from the steering column switch unit H5 and the go ahead with the main beam or dipped headlamps on.

Brilliant thanks!

Plenty to go on and explore!

1. So the relay is in the engine bay fuse box yes?

2. I may have spilled fluid whilst changing the Coolant Tank above the Motor connectors; maybe this triggered the fault?

3. I only tested the headlight jets with lights off I didn't realise the lights had to be on so I'd better check with that!

Thanks!

:thumbup:
 

·
Registered
Joined
·
2,945 Posts
In an early 156 manual, I seem to remember it detailed how the washer pump would only operate something like every 3rd operation if the washers were operated within about 10 minutes.

The power wash relay is located in the 156 just above the glove box. There is a small cover in the top which must be levered out. Small hands help.

Perhaps the 147 is the same but I've never checked.
 

·
Premium Member
Joined
·
7,522 Posts
Brilliant thanks!
Plenty to go on and explore!

1. So the relay is in the engine bay fuse box yes?

2. I may have spilled fluid whilst changing the Coolant Tank above the Motor connectors; maybe this triggered the fault?

3. I only tested the headlight jets with lights off I didn't realise the lights had to be on so I'd better check with that!
1. yes, near the battery
2. no. Should all be waterproof ;)
3. yes, only with lights on
 

Attachments

1 - 5 of 5 Posts
Top