Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi.

I own an Alfa Romeo Giulietta Sprint. It is a 1.4 manual with a 150HP, I really love it however something's bothering me. Manufacturer states it will do 0-60 in 8.2 seconds. But it feels a lot faster than that. I described this to my friend and he said some manufacturers quoted 60 times aren't entirely accurate.
Any knowledge on the matter?

Thanks in advance
 

·
Registered
Joined
·
231 Posts
Take it all with a pinch of salt.

ive seen varying times from 7.2 - 8.5 via OBD reader in my 170 MA. Think it just depends on how the car feels that day.
 

·
Registered
Joined
·
4,932 Posts
I believe italian manufacturers measure 0-60 performance with half a tank of fuel and an extra passenger so they usually do better than quoted.
 

·
Registered
Joined
·
38,706 Posts
Funny, mine is meant to do 0-60mph in 7.8 seconds and to be honest I reckon it is slower.

That initial 0-30mph get away makes it slower than most cars. I have even been out dragged by a Landrover freelander which is meant to be slower...

The previous car was a Renaultsport Clio 172 cup, and that would leave most cars at the lights without ever trying.
 

·
Registered
Joined
·
336 Posts
Funny, mine is meant to do 0-60mph in 7.8 seconds and to be honest I reckon it is slower.

That initial 0-30mph get away makes it slower than most cars. I have even been out dragged by a Landrover freelander which is meant to be slower...

The previous car was a Renaultsport Clio 172 cup, and that would leave most cars at the lights without ever trying.
I feel the same!

But I have to admit, I don't do dramatic starts of the line. But from second gear it flies (Manual Multiair)
 

·
Registered
Joined
·
28 Posts
Mine is an 170MA with TCT. It's hopelessly slow at starting (and getting into 1st gear), but gets better afterwards. Definitely slower than official 7.x sec.

p.s. haven't tried using "launch control" function for fear of burning the clutch...
 

·
Registered
Joined
·
247 Posts
Mine is an 170MA with TCT. It's hopelessly slow at starting (and getting into 1st gear), but gets better afterwards. Definitely slower than official 7.x sec.

p.s. haven't tried using "launch control" function for fear of burning the clutch...
Go on give it a go, its hilarious! :)
 

·
Registered
Joined
·
3,088 Posts
Official acceleration times are always quoted for 0-100 km/h, which is 0 to 62 mph. You'll hit 60 a tiny bit sooner than that.

Giulietta is deceptively fast. The ride is pretty well sorted during acceleration, so it never feels like it's going as fast as it really is, but it's a pretty fast car for its engine sizes.
 

·
Registered
Joined
·
4,932 Posts
I always found my Giulietta to be hard to launch. Either the turbo would stall and I would wheeze off the line or the wheels would spin up and the the front end would start juddering. Perfect with a rolling start though.
 

·
Registered
Joined
·
38,706 Posts
Official acceleration times are always quoted for 0-100 km/h, which is 0 to 62 mph. You'll hit 60 a tiny bit sooner than that.

Giulietta is deceptively fast. The ride is pretty well sorted during acceleration, so it never feels like it's going as fast as it really is, but it's a pretty fast car for its engine sizes.
Trust me it isnt fast. Not until it is rolling anyway.
 

·
Registered
Joined
·
8,786 Posts
Funny, mine is meant to do 0-60mph in 7.8 seconds and to be honest I reckon it is slower.

That initial 0-30mph get away makes it slower than most cars. I have even been out dragged by a Landrover freelander which is meant to be slower...

The previous car was a Renaultsport Clio 172 cup, and that would leave most cars at the lights without ever trying.
the tct is quite fast on take-off. yards only to reach 30 mph.
 

·
Registered
Joined
·
8,786 Posts
Mine is an 170MA with TCT. It's hopelessly slow at starting (and getting into 1st gear), but gets better afterwards. Definitely slower than official 7.x sec.

p.s. haven't tried using "launch control" function for fear of burning the clutch...
changing down to 1st gear is not something the tct wants to do by itself... but it does if you flip the paddle.

edit: I used launch control once. It's not the clutch you need to worry about, it won't slip. But you won't get any traction either. seems like all traction control is turned off.
 
1 - 13 of 13 Posts
Top