Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
926 Posts
Discussion Starter #1 (Edited)
Just connected mine to FiatECUScan via bluetooth to test the EGR operation

Tested the connection was working by turning on and off warning lights, so far so good.

Removed the engine cover and started the EGR test while holding the solinoid. Nothing:eek: I Know the solinoid itself works as last weekend I removed it and tested it by 12v across the terminals and it was click away happly

Does anyone have a 16v 156 jtd & FiatECUScan. If you do could you do the same actuator test and see if you can feel the solinoid clicking.
Please. I know it's cold!;)
 

·
Registered
Joined
·
9,912 Posts
Just connected mine to FiatECUScan via bluetooth to test the EGR operation

Tested the connection was working by turning on and off warning lights, so far so good.

Removed the engine cover and started the EGR test while holding the solinoid. Nothing:eek: I Know the solinoid itself works as last weekend I removed it and tested it by 12v across the terminals and it was click away happly

Does anyone have a 16v 156 jtd & FiatECUScan. If you do could you do the same actuator test and see if you can feel the solinoid clicking.
Please. I know it's cold!;)
dont have to ..it should click
 

·
Registered
Joined
·
926 Posts
Discussion Starter #3
Kind of what's thought. Need a circuit tester to see if it's getting any voltage though.

And a warm jacket
 

·
Registered
Joined
·
926 Posts
Discussion Starter #5
Connected a multi meter to the terminals to check if working when I trigger the EGR, didn’t work at first so I scrapped the connectors clean!
Plugged it back onto the solenoid and triggered it again, bugger me if it aint working again!!!

Must have been crap on the connectors! Nice cheap fix just as I like them!
 
1 - 5 of 5 Posts
Top