Alfa Romeo Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
461 Posts
Discussion Starter · #1 ·
I've now had three unsuccessful attempts to upload 1052. I keep getting error 0x800703EE even with Norton turned off. Any one successfully downloaded it? After eleven previous successful updates I'm puzzled.
 

·
Registered
2019 Milano; Mazda MX5
Joined
·
707 Posts
I've downloaded the maps and licence ok (eventually)
It's getting the car to accept it thats been the problem. Even the dealer hasn't managed it yet.
 

·
Registered
Joined
·
187 Posts
I had to do a full format of the memory stick before i could get it to work on my Stelvio...only time this happened.
 

·
Registered
Joined
·
2,288 Posts
I can't get any more updates, the car turned 3 in July. I've contacted the dealer and they referred me to the Mopar map website !! I don't mind paying for the updates just need to know how to get them?
 

·
Registered
2017 Giulia Speciale
Joined
·
403 Posts
I downloaded the map update and licence after the 3 year anniversary of my warranty / registration date. I'm just waiting for a suitable journey to install it.
 

·
Registered
Joined
·
494 Posts
Did mine yesterday, first attempt as it’s a new car to me but no problems....but glad it’s not something you have to do every week. I now know where I live!

Used the guide on here.
 

·
Registered
2017 Giulia Speciale
Joined
·
403 Posts
Can I ask where from? Was it on the same website or did a dealer do something for you?
It was from the same Mopar site as previously. Having said that my warranty was extended beyond 36 months to 38 due to Covid to cover work it had been booked in for.
 

·
Registered
Joined
·
179 Posts
Downloaded and installed 1052 today with no issues whatsoever. Mine is a MY2018 Quad. Second update I’ve done since I’ve had the car from new
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #12 ·
Finally downloaded 1052 successfully and installed today. It said 216 minutes to install but did it in 76. This was because I just bought 3 years updates for £119 until 2023, despite unsuccessfully trying to download it a few days before the 3 year expiry.
 

·
Registered
Joined
·
584 Posts
Seems a tad expensive bearing in mind the system is not one of the best!

Think I'm inclined to stick with Waze or Google Maps on my phone and the inherent free real time info that provides. ;) Waze has saved me from mobile speed traps on many occasions! 👮‍♂️
 

·
Registered
Joined
·
217 Posts
Anyone having problems even getting into myalfaromeo/Mopar? I used to be able to login and see my car and service pack etc. Just doesn’t seem to work anymore.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
55 Posts
Alfa confirmed error with 1056 and now have uplaoded a new version - this still does not load as it says current map is newer than the one your trying to upload !!
 

·
Registered
Joined
·
10 Posts
Alfa confirmed error with 1056 and now have uplaoded a new version - this still does not load as it says current map is newer than the one your trying to upload !!
I have had exactly the same problem - looks like they don't know what they are doing! Normally the maps provided by Mopar have the same version no as the maps released by TomTom for their devices, although we get them 2 - 3 weeks later. Funnily enough TomTom don't have a version 1056, see link - Latest maps for navigation devices. !!!
 

·
Registered
Joined
·
55 Posts
i had
I have had exactly the same problem - looks like they don't know what they are doing! Normally the maps provided by Mopar have the same version no as the maps released by TomTom for their devices, although we get them 2 - 3 weeks later. Funnily enough TomTom don't have a version 1056, see link - Latest maps for navigation devices. !!!
i had a call from Alfa Italia this mornign and they have confirmed the issue and have took it down again !!
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top