Alfa Romeo Forum banner

1 - 20 of 45 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1

·
Registered
Joined
·
122 Posts
Hi, go for it i have the same blades, they fit very well and the spray is ok although not as good as the spray bars.
 

·
Registered
Joined
·
93 Posts
Bought some Wipex blades the other day - V easy to fit and seem to be really good - nice even wipe at the moment.
Go for it - think the wipex ones were about the same price also.
Cheers
Colin
 

·
Registered
Joined
·
1,577 Posts
Got some the other day too, bit fiddly to fit (the clips that hold the tubing in, dont fit the replacement tubing), but look good, I find the spray much better than the old one (though one of the old tubes was knackered) and the wiping is muich better, silent and even. Do it :)

I suspect all the ones on ebay are the wipex ones, most have the same picture..

ETA: I got these, a few £ cheaper than the link you posted : http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=200308978932&ssPageName=STRK:MEWNX:IT
 
A

·
Guest
Joined
·
0 Posts
I have had them on for twelve months or so.
They were very good at first - very quiet and cleared the water well.
Now not so good - they dont seem to follow the profile of the widnscreen anymore so they leave a fair bit of streaking.
 

·
Registered
Joined
·
2,142 Posts
I fitted wipex ones recently. Have to almost stretch the pipes to fit to the jets but seem to work so far. Flow is reduced but seems sufficient. So far a big improvement although drivers side lifts slightly on return wipe - will swap them round to see if its just that blade.
 

·
Registered
Joined
·
93 Posts
I fitted wipex ones recently. Have to almost stretch the pipes to fit to the jets but seem to work so far. Flow is reduced but seems sufficient. So far a big improvement although drivers side lifts slightly on return wipe - will swap them round to see if its just that blade.
Simon did Wipex not send you extra lengths of pipe and connectors?? did with mine fit fine the hardest part of the job was getting the old ones off!!
 

·
Registered
Joined
·
458 Posts
ive fitted some. they are ok,>>

im not 100% happy with the look of the water 'bulb' ... kinda bulky imo...

other than that they work well.
 

·
Registered
Joined
·
2,142 Posts
Simon did Wipex not send you extra lengths of pipe and connectors?? did with mine fit fine the hardest part of the job was getting the old ones off!!
Think they did actually but got away with it as is. Unless thats a reason for the restricted flow?
 

·
Registered
Joined
·
43 Posts
I fitted them about 1 year ago and at first they did the job but already after 6 months the rubbers were worn. Also at higher speeds they do not press down enough. They look great but I switched back to originals and they perform much better.
 

·
Registered
Joined
·
80 Posts
I have had them on for twelve months or so.
They were very good at first - very quiet and cleared the water well.
Now not so good - they dont seem to follow the profile of the widnscreen anymore so they leave a fair bit of streaking.
I've had wipex for 1 year as well and they are starting to leave streaking.
Seams then they only last a year.
Still better than standard though so will re-order some.
 

·
Registered
Joined
·
834 Posts
Does anyone know if the GTV Wipex wipers are the same for the Spider? The Wipex website shows both conventional and also the flat wipers as 21" and 19" for the GTV, but 21" and 16" for the Spider, whereas there Ebay listings don't show a difference? I have a phase 3 Spider. Thanks
 

·
Registered
Joined
·
2,877 Posts
Spider is the same as a GTV - God knows where this 16" malarkey came from.

From memory the measurements are 21" and 19".
 

·
Registered
Joined
·
1,450 Posts
I've bought a set of these wipers and put 'em on, only to realise that the little plastic outlet that the tubing goes onto on the scuttle panel is broken and leaking water :( Any ideas where I can get a replacement?
 

·
Registered
Joined
·
834 Posts
Well I went ahead and got myself the Wipex flat blades from the 'bay and I'm disappointed tbh... They judder and the drivers side blade doesn't contact the screen evenly, leaving an uncleared patch. Such a shame Bosch don't do these for the spider/gtv cos I'm sure they'd work better and look a lot sleeker too. Maybe the issues I'm having are a one off so I've asked for a replacement set, lets see what happens.
 

·
Registered
Joined
·
3,189 Posts
If anyone wants a genuine Alfa Romeo set with the clips for the washer jet tubes posted to a UK mainland address for £17 let me know - retail price is about £29.
 
1 - 20 of 45 Posts
Top