Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Only had my gt jts a month probably done about 500 miles and I've already put a litre of oil in it. Being as im not sure when oil n filter was last changed if they used 10w40 instead of the 10w60 could that explain the high oil usage when I got the car I had to add 1/2 a litre to get it on the gauge :(. So basically is this normal or do I have to do an oil change and go from there ?
 

·
Registered
Joined
·
2,757 Posts
Its on the high side definitely...

I would change oil and filter and gauge it from there.

I had a jts GT before my 1.9 bkackline and went through a litte of 10/60 every thousand miles or so but that in 500 is a concern.

Did find the annoying flat dipstick difficult to read sometimes and if often took me a couple of goes to get a clear reading.

So it could just be a combination of lowish oil to begin with and ab ambiguous dipstick reading.

Good luck,hope it settles down.
 

·
Registered
Joined
·
2,657 Posts
Like Joey says, firstly change the oil and filter, use 10W60. Generally direct injection engines tend to dilute/contaminate the engine oil with petrol so you want to change the oil regularly, I do my JTS every 10,000km (6k miles) and it's been great.
 

·
Vendor
Joined
·
46,352 Posts
So it could just be a combination of lowish oil to begin with and ab ambiguous dipstick reading.
This is a good point. I would do an oil & filter change and go from there. Oil that is old and broken down will burn faster.
 
1 - 4 of 4 Posts
Top