Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
As the title says, front suspenssion knock on low speed, cant pinpoint the side. Going over speedbumps with only right wheel, the knock is so hard i can feel it under my feet.

So far i have replaced:

1x both lower wishbones
2x both upper wishbones
3x both droplinks
1x all 4 shocks
1x both top shock mounts

Issue still persists for more than one year, 3-4 different garages cant find the problem

Only thing that is left, arb bushes, and just maybe track rod ends.


Does someone have any idea or something?

Sent from my SM-G970F using Tapatalk
 

·
Registered
Joined
·
3,792 Posts
Mine was lower rear engine mount (the dog bone shape one roughly inline with the pedals.....just a thought.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I have changed one of those, longer one if i remember correctly. I think that one is closer to the gearbox. Which one did you change?

Sent from my SM-G970F using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
I will check that in 2 weeks. I will be changing water pump then. I have forgot to mention that this is 2.2 Jts, the mounts are a bit different

Sent from my SM-G970F using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Left the car in the garage for them to find the knock. I have just picked it up, they say everything is perfect, they have even changed one ARB drop link, they didnt want to charge since problem was not solved. Every bolt was checked, steering rack, whole suspension, everything is perfect. 2 things are left, engine mounts, or strut bearings...Or, some magic like hoses clunking on the bare metal somewherex, or some similar bull***t.

Sent from my SM-G970F using Tapatalk
 

·
Registered
Joined
·
5 Posts
Got a rattle when going over small holes etc too.
The Brera is being ramped next week, subframe removed and refurbed. Picked up new short and long stabiliser fittings (gearbox short and rear engine longer) you mentioned as the rubber is perishing on the ones I have. Mines a 2.4 on a 2010.
See if it makes any changes
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
It was the freaking


bonnet...


It had play in the latch, up and down. I have put some duct tape on the bonnet latch, and the noise stopped. Now, im sorry for the money on 3x new suspenssion

I can sell the car now, and get giulietta qv.

Sent from my SM-G970F using Tapatalk
 
1 - 8 of 8 Posts
Top