Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,370 Posts
Discussion Starter #1
Well the heading says it all they aren't working and I can't see where they are fitted. Definite MOT failure so needs fixing.

1984 model so will they be fed via a fuse and relay or just a fuse? I don't really trust the Haynes manual and being a reprinted edition the wiring diagram really isn't very clear.
 

·
AO Detailing COTY Winner 2018
Joined
·
547 Posts
Well the heading says it all they aren't working and I can't see where they are fitted. Definite MOT failure so needs fixing.

1984 model so will they be fed via a fuse and relay or just a fuse? I don't really trust the Haynes manual and being a reprinted edition the wiring diagram really isn't very clear.
On my Alfetta saloon there are two horns (high and low tone), one each side, low down at the very front. They are almost behind the bumper, and there are louvres in the front valence especially for them. Mine are on a fuse but not a relay, although car was built in 1979 and maybe later ones did have a relay...

See attached photo.
 

Attachments

·
Registered
Joined
·
680 Posts
Hi one the Alfetta GTV and GTV6 there are two. Remove the left or right headlight and you will see a horn secured by an 10mm nut and one spade connector.

Normally they just need a clean as she'll have a bad earth.

Cheers,
Peter
 

·
Registered
Joined
·
2,370 Posts
Discussion Starter #4
Thank you.

Similar cars in ownership.

159 and GTV. GTV been off the raod for 10 years but heading for a return. Target is back on the road and drive it to Goodwood Revival.
 
1 - 4 of 4 Posts
Top