Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Here's one for yer,

Just bought ALFADIAG, looking good so far.....came up with this code on the selespeed ECU....

P0725 Engine Speed input Circuit Malfunction

Self explanatory to some degree, could someone with the know how, be kind enough to elaborate for me?

John:)

2000' Selespeed SW
 

·
Registered
Joined
·
9,340 Posts
Could be the speedo sender on the gearbox. You'll find it on the front side of the box near the filler plug.
 

·
Registered
Joined
·
224 Posts
Incidently blueji. what were the symptoms of your problem?

I am currently having issues relating to my Selespeed, it has something to do with engine speed, until I get my cable I am in the dark.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #6
Incidently blueji. what were the symptoms of your problem?

I am currently having issues relating to my Selespeed, it has something to do with engine speed, until I get my cable I am in the dark.
No particular problem prompted me to think there was a problem with the selespeed, apart from erratic rapid 'beeps' when I engage reverse, I bought a new heavy duty battery which seemed to cure it. (forum suggestion) The beeps have come back and just lately when the car is at running temp, it drags when I engage 1st or reverse, so I bought ALFADIAG (today)to check the clutch rod length. Still need to check that.

On checking the fault codes though, the SELE ECU threw up P0725:confused:

I don't have any mechanical or gear change problems......YET:rolleyes:
 

·
Registered
Joined
·
82 Posts
Discussion Starter #7
P1760 Pressure Control Solenoid "A" Short Circuit

Latest code from the sele ECU, any body come accross this one?......

John:(
 
1 - 7 of 7 Posts
Top