Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hi all, unfortunately my Alfa broke down yesterday.... I was travelling on the M1 when the car seemed to lose power and then there was a loud knocking sound from the engine......I managed to get it a few hundred yards off the M1 and onto a side road then it just stopped altogether.....I have been told by a friend that it is possibly a snapped cambelt.....anyone know what damage this could have caused as it made one hell of a knocking sound and now it wont turn over at all.....would appreciate any help and advice.....Thank you....Steve.
 

·
Registered
Joined
·
447 Posts
I'd get it into Autolusso (In houghton Regis near luton) to get them to have a look at it. They do have a service to tow it in if your recovery wont get it there.

Autolusso - Alfa Romeo Specialist | Home
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Hi Chris, have had the car towed back to my house........I am in Northampton......Unfortunately I know absolutely nothing about the mechanics of a car so am unable to "look" to see what may be the problem.....Thanks for your reply....Steve
 

·
Registered
Joined
·
4,097 Posts
to be honest, the best thing you can do now is give the guys at autolusso a call, they will let you know what all the options are. or alternatively, if you fancy getting handy with the spanners, i think anjenha on here is selling the engine out of her spider :thumbs:
 
1 - 4 of 4 Posts
Top