Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi Guys,

I bought an Alfa Romeo Mito 1.4 T-jet LPG 155cv.
During the trial run I had some fault codes (P0300-P0304; P0240; P0037) on Petrol system on high RPM over 4000
I have started to review the system:
- Check plugs - it looks good
- Check coils - it looks good
- Check turbo pressure - it looks good but not acces to the engine. If it check the pressure on the board (whit the bars) it fill just the half

At the moment I don't know what could the real problem.
have Somebody met this problems?
Misfire, turbo pressure and lambda problem

Please help
 

Attachments

·
Administrator
Joined
·
87,588 Posts
S

·
Guest
Joined
·
0 Posts
Welcome To‵⁀) ✫ ✫ ✫.
`⋎´✫¸.•°*”˜˜”*°•✫
..✫¸.•°*”˜˜”*°•.✫
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛° 。* °♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I'm not so happy. Yesterday I have took my MiTo to the service. But in the afternoon they call me. This engine has LPG system. They did not dare to touch the engine... fck... Therefore I have to find other service with enough knowledge and experience with in 1.4 Tjet and LPG system. I think that will be difficult! But let's try! :)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Update: Yesterday I have spoken the service guy. On LPG mode there is no failure. On gasoline mode when the engine is hot there is also no failure, But when the engine cold the misfire is available yet. They have to re-cable the ignition. The boost problem also solved.
I hope they will find the real root cause of the misfire.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Update: last Friday I have spoken again with the service guy. At the moment there is no misfire no LPG and petrol but! The turbo pressure not solved.
It looks the timing is the problem. higher RPM the timing not change therefore the not create enough exhaust gas to make turbo pressure just around the half of the full.
Today service will check the timing.
What do you think guys?
 
S

·
Guest
Joined
·
0 Posts
Welcome To‵⁀) ✫ ✫ ✫.
`⋎´✫¸.•°*”˜˜”*°•✫
..✫¸.•°*”˜˜”*°•.✫
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛° 。* °♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Update: last Friday I have spoken again with the service guy. At the moment there is no misfire no LPG and petrol but! The turbo pressure not solved.
It looks the timing is the problem. higher RPM the timing not change therefore the not create enough exhaust gas to make turbo pressure just around the half of the full.
Today service will check the timing.
What do you think guys?
Hi Guys, new updated!
We have found the real causer! That cause the misfire and turbo pressure problem.
Problem is dead catalizator.
On the down pipe we measure the exhaust gas pressure on lambda hole it was 2BAR...:furious:
10x of the acceptable value.
We will start the operation in this week.
I hope it will solve my problem! :thumbup::yes:
 
1 - 12 of 12 Posts
Top