Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
The hazzards have stopped working on my 33 series 2. When the engine is off and I switch them on they dont't come on and I can hear a slight buzz from under the dash - can anyone
tell me where the controller is - is it under the dash or in the engine bay? I have changed the switch and the 'red' relay by the battery with spares so it doesn't seem to be either of them.
 

·
Banned
Joined
·
10,277 Posts
:confused:

You've lost me mate ! What spare batteries ? and why would the hazard lights go on when the engine is off ?

In any case, the relay is under the dash on the drivers side.
Its not on the fusebox though like the other relays.

If you take off the dash/speaker cover on the lower side of the drivers side, you will find that there are 2 relays bolted on in from the top side.
One is for the hazard lights and the other one if I remember correctly, is for the central locking system.

If you can hear a very thin like buzz sound, it means that there is poor contact on the relay, or the relay is shot.

Hope this helps
 

·
Registered
Joined
·
1,468 Posts
...and why would the hazard lights go on when the engine is off ?
Not only can they operate when the ignition's off (as in just about every car I would think), in the case of my 33, the radio goes if the hazard lights are switched on. That's so you can listen to it while you wait for the towtruck.:p

Seriously though, the red relay by the battery is for the headlights I think. The hazard light buzzing will be as suggested - coming from the relay under the dash, which will either be faulty or affected by a loose connection somewhere.
 
1 - 4 of 4 Posts
Top