Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hello everybody,

Some weeks ago the climate control of me alfa 159 1.8 MPI, started malfunctioning. I have noticed that the air distribution is not working properly. You can see the type of climate control system that my car has in the attached picture. As you can see it is manual monozone climate control system.

Problem description
The problem is that the air distribution works arbitrarily. I mean that the air does not always come out from the appropriate ducts according to where the air distribution knob is pointing. So, sometimes I move the air distribution knob and the air distribution follows correctly (rare situation). Some other times (most times) I will move the air distribution knob and the air will come out from different ducts. And some other times even if I move the air distribution knob, the air distribution will not respond and the air will continue coming out from the same ducts. Does anyone know what could be the fault ?? Anyone that had similar experience ??

p.s: I have connected to my climate control system using ALFAOBD and it didnt gave me any stored fault errors..

Thank you
 

Attachments

·
Registered
Joined
·
18 Posts
Mine's a bit odd with that as well, been meaning to ask about it for a while. The drivers side window demister always has flow but the vent below it does precious little. I find it dries my eyes a little on mid-full flow. I rarely set the temp above 17 and have the fan above two notches but it is irritating when the car decides it knows best and sets the flow on my behalf. I think I'm getting old: at one point it was exciting to have a car with all this elec-trickery but nowadays the auto lights, auto wipers and climate control just annoy me. I'd much rather have a system like yours with one knob for heat, one for fan and one for direction. I'd also like a proper intermittant wiper setting instead of the guesswork my car relies on and that bloody sensor that switches the air con on every two seconds has surely been calibrated to cause maximum grief.
 

·
Registered
Joined
·
775 Posts
Since you're having the basic climate control, may it be controlled by a wire instead of electric motors.

If you remove the radio should you be able to see behind.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
There are no wires in the climate control systems.. THe knobs are still electrical controls..
I came up with some new information. I connected my Climate control ECU to MultiEcuScan and it gives me 2 errors (see attached picture).. As I describe in the problem description of my first thread, my problem is with the air distribution only, THe air mixer works OK..



After seeing the errors, I tried the two Actuator tests as you can see in the video... http://youtu.be/sSJm6ZTsdNQ
By running these two tests I didnt notice any change in the air mixer temperature neither in the air distribution.. As the video shows the duration of these two tests is quite short and I dont know if it is enough so that you can notice any change in the air mixer or air distribution in such a short time period...

1) Do these tests have a short duration in your cars as well guys ???
2) Do you know what might be the cause of my climate system malfunction and it doesnt distribute air correctly ??

THank you
 

Attachments

·
Registered
Joined
·
2 Posts
Hello everybody,

Some weeks ago the climate control of me alfa 159 1.8 MPI, started malfunctioning. I have noticed that the air distribution is not working properly. You can see the type of climate control system that my car has in the attached picture. As you can see it is manual monozone climate control system.

Problem description
The problem is that the air distribution works arbitrarily. I mean that the air does not always come out from the appropriate ducts according to where the air distribution knob is pointing. So, sometimes I move the air distribution knob and the air distribution follows correctly (rare situation). Some other times (most times) I will move the air distribution knob and the air will come out from different ducts. And some other times even if I move the air distribution knob, the air distribution will not respond and the air will continue coming out from the same ducts. Does anyone know what could be the fault ?? Anyone that had similar experience ??

p.s: I have connected to my climate control system using ALFAOBD and it didnt gave me any stored fault errors..

Thank you
I know this thread is old but I’ve been searching for an answer for the same issue you had with your manual heating control, did you resolve it , if so what was the fix ?
thanks
 

·
Registered
Joined
·
214 Posts
check the E-LEARN manual, it has some wiring schematics. I believe all components are sort of "daisy chained" from the control unit. I've had some issues in the past, turned out to be a loose connection.
 
1 - 9 of 9 Posts
Top