Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hi AO peoples, I am going to have a look at a Alfa Romeo 147 Collezione 2007 (1.6 petrol) 83,000 miles Just wanted to know what I should look for when I go and have a look today any help would be greatly appreciated cheers!!!! :cool:
 
G

·
Guest
Joined
·
0 Posts
The usual stuff . Cambelt history should have been done twice on that mileage.£400 at the indies!
Steering/suspension bushes (listen for squeaks and knocking) check the electrics all work and the dash lights all go out when it's started. Have a look underneath see if there are any signs of rust on the sills or the floor.
The exhausts have a tendency to rust .
The other is the camshaft variator (diesel like rattle at tick over)
Just use a bit of common sense rather than your heart ;)
Hope it's a good one :thumbs:
 

·
Registered
Joined
·
551 Posts
Beyond the usual Alfa stuff like knocks and bangs from suspension (front and back), uneven tyre wear etc have a look at the oil level and check the aircon is ice-cold and the handbrake actually works.
 
G

·
Guest
Joined
·
0 Posts
+1 :thumbs:
Oh yeah start it let it run till it reaches running temp (temp gauge at 90 deg about in the middle of dial) then when you drive it make sure it stays there give or take a couple of deg even on a dual carriage way at speed .
 
G

·
Guest
Joined
·
0 Posts
Hope you enjoy it :thumbs:
Just make sure you check the oil regularly they do use a bit of oil and they don't like running on low oil ok.
 
1 - 8 of 8 Posts
Top