Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
First of all, hi everyone, my name is Alex ! Second, i know this problem has been up for debate on several occasions on this forums, and i have read all of them several times for tips on fixing my problem, none have worked.

My problem is the driverside window kinda stutters , it will not go up and down in one motion, i have to press multiple times. Sometimes its just plain stuck . Heres what ive done : I bought two brand new window control units, one for passenger side and drivers side, did not fix the problem. I removed the door card and checked all connections, cleaned them and lubed the rail thingy the window glides on, did not fix the problem. I bought a brand new battery, did not fix the problem. I tried soft reset , hard reset, all that stuff... still, did not fix the problem.

I am out of ideas, the motor that moves the window sounds ok so i dont believe its broken, its kinda slow though.. seems like the only thing left i have not done anything about (like buying a new one). Does anybody here have any other idea about what to try next ? its been a real pain in the ass :) Added a photo of the car , since im new to the forum so wanna show it :) :thumbup:
 

Attachments

·
Premium Member
Joined
·
2,038 Posts
Velkommen til AO, det ar en fantastisk GT!! :thumbup:

GT's came factory fitted with window demons, it's not an option you could de-select either. Like you said there isn't much left for you to replace, have you watched the mechanism working with the door card off? If the regulators are fine and only one side has issues then it does sound like the mechanism is catching on something. Best of luck sorting it.

:thumbs:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
I used silicone spray lubricant . Now it seems it doesnt move at all, although that small "blackbox" with the ecu makes loud clicking noises, i suspect thats my problem, so i ordered a new part, this time sw15, ive heard theyre better, ill let u guys know how it all turns out. Crossing my fingers, hoping this will be the end of the window nightmare :D

Thanks for compliments on the GT :D
 

·
Registered
Joined
·
68 Posts
I have had almost the same problem in my 156 on the front right window, it was even going down on its own and stuttering. I followed the cables from the door to the window control unit, tested the cables in a manual method, cut the concerned cables and bought two cheap standard relays relays, got current from the glove box sensor cables, connected them and everything works fine now !
the clicking noise is coming from the relays, they tend to go crazy by time and you have to pay hundreds to replace them(at least here in my country where alfa romeo is extremely rare).
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Lemme just finish up this thread, I basically just bought a new window regulator and replaced the old one, the job is quick you just do it yourself , and the price for a new regulator isn't that much, mine was 200?. Problem fixed.
 

·
Premium Member
Joined
·
2,038 Posts
Lemme just finish up this thread, I basically just bought a new window regulator and replaced the old one, the job is quick you just do it yourself , and the price for a new regulator isn't that much, mine was 200?. Problem fixed.
Yeah, not a bad job to change these. I do think Alfa could have made the door card easier to remove though. On your own it’s a pain to get the top of the door card seated the the window whilst aligning those plastic tabs. And most of the time I broke the thumb tabs on the door handles getting them out. :thumbs:
 
1 - 9 of 9 Posts
Top