Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hi

would appreciae any help/suggestions

I have a Alfa GT 2.0 JTS with £3500 Miles. Looks like the head gasket has failed. When the car is running for few minutes clear smoke starts comming out of exhaust and also the temp reaches the middle fairly quickly,

Iv checked the oil cap and there what everyone seems to call mayonaisse under the cap.

Today when I started the engine I could hear a ticking sound from the engine. Could be the timing belt is in need of change.

I know to expect a hefty bill.

Can anyone reccommend anyone to do the job and idea of costs please

thanks
 

·
Registered
Joined
·
1,563 Posts
Hi

would appreciae any help/suggestions

I have a Alfa GT 2.0 JTS with £3500 Miles. Looks like the head gasket has failed. When the car is running for few minutes clear smoke starts comming out of exhaust and also the temp reaches the middle fairly quickly,

Iv checked the oil cap and there what everyone seems to call mayonaisse under the cap.

Today when I started the engine I could hear a ticking sound from the engine. Could be the timing belt is in need of change.

I know to expect a hefty bill.

Can anyone reccommend anyone to do the job and idea of costs please

thanks
Most Alfa's produce quite alot of "smoke" out of the exhaust until very warm, more like condensation then any particular colour though , sometimes it can look like the car is in trouble but it really isn't.

Have you checked your coolant level, normally it takes a few minutes to get to 50 degree and a few minutes again of normal driving to get near driving temperature.

Mayo - do you drive the car on many short journeys? as this can just be moisture from the car not getting up to temp enough. I would clear the mayo and recheck after a proper ride (as well as getting the coolant checked for signs of contaminants).

Ticking is hard to diagnose - in all cases an Alfa specialist will no doubt be in your area and ready to help! :thumbs:
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
Thanks for replies

Iv not had car long. I do think its bit too smoke for it to be condensation.anyway to check?

Also car seems to get to driving position even if left running on drive for few minutes
 

·
Registered
Joined
·
1,563 Posts
Thanks for replies

Iv not had car long. I do think its bit too smoke for it to be condensation.anyway to check?

Also car seems to get to driving position even if left running on drive for few minutes
You will be surprised if this is your first Alfa, when at lights it seems to be pushing out almost the same amount of "smoke" as when a turbo goes, happened on my 7k mile Alfa 156, my current GT...in fact all of the TS/JTS based cars.
 
1 - 5 of 5 Posts
Top