Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi all

First Alfa first post

Today I bought a 04 GT 75K on the clock, full service history lots of receipts. Everything seemed fine on the test drive so I went ahead and bought.

I got it home from Watford to South London without any problems but when I went to take it out an hour later the 'motor control system failure light came on' and the engine whined horribly when I steered in either direction. I also noticed a pool of steering fluid underneath the drivers side (I've checked the fluid level and its low).

I'm pretty angry and upset and I haven't had a call back from the previous owner. Initially I thought the number of receipts for work done at ProAlfa in Watford was a good sign but he spent £1500 in 6 months so perhaps the car is prone to probs.

Anyway I appreciate anyone's advice on a few things

Does it sound like I have bought a lemon, is there anything else I could check?
Is the steering problem the pump?
Is the car safe to drive to a garage to get the problem sorted?

Any advice would be great. I'm off to stare longingly at my broken GT as it glistens in the snow :(

Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks dhillion does that explain that motor control failure light too and can it be driven to a garage without first damage? Sorry for the questions, my mechanical knowledge is slim to none - they should teach this stuff in school!
 

·
Registered
Joined
·
13,685 Posts
Motor Control failure could be something else. Not long after buying my 1.9JTD the lower turbo hose went. I also at that time had a 'water in fuel filter' warning and the MCF message appeared and stayed on. I replaced the hose after a couple of weeks and the light and message remained for about a week. I was about to do the diag (bought a blue tooth OBDII connector) and low and behold the light and consequently the message stopped before I connected it :lol:

Anyway I would take it to have a diagnostics on the car and doubt the steering pump is why the light and message appears.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks malc will do. I knew alfas were temperamental but I didn't think I'd be looking at a trip to the garage 3 hours after buying it - must be a record :)
 

·
Registered
Joined
·
13,685 Posts
Just the luck of the draw. I think today with the electrickery currently employed on modern cars issues seem to readily manifest themselves :lol:

Suspension bushes (wishbones) and anti-rollbar drop links do seem to be a particular problem.
The lower turbo hose is a known issue. The hose wears on a gearbox bolt!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks. Quick update I topped up the steering fluid which stopped the whining and extinguished the warning light. The fluid has come straight out the other end so it will going to to alfacraft tomorrow. Can't believe that the previous owner didn't know about it (he hasn't returned my calls )

Lesson learned. Thanks v much for your help
 

·
Registered
Joined
·
7,479 Posts
Hope you get it sorted ok. The JTD engine is bullet proof, if you look after your GT you'll get great fun out of it. Make sure though that at 75,000 miles the cambelt/tensioner/idler has been done and also the waterpump as well. I say 'bullet proof' as the only weak link on this JTD 16v engine is the waterpump.
 

·
Registered
Joined
·
5,266 Posts
If it was a private sale you have very little comeback against the previous owner, I wouldn't even bother trying to contact him to be honest..
 
1 - 9 of 9 Posts
Top