Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1 (Edited)
Alfa gt not got definitive answer can anybody help

Is there anyone who could help me i have read all the posts on my recent problem which was, i was driving along, car cut out, battery low light came and the Immobilizer failure light came on and stayed on,pulled over turned key started all lights gone out and was ok and has been for 5 days but i thought i need to see what the fault was.
My local garage plugged it in, there were no fault codes for the immobilizer, the only codes it showed were(P0300 Random multiple cylinder misfire detected) and (P0304 Cylinder 4 Misfire detected) i got the interpretations from the Forum but my garage were unable to say if i needed to replace any faulty item.
Is it possible as the two codes both showed a misfire this was caused by the immobilizer cutting in as that would cause a misfire surely.
I did speak to one of the independant Alafa garages and they would not comment on the codes they would like to see the car but as i am 2hrs from them it does make it a little difficult.
Sorry i didn't say the car is a Alfa GT 156 2litre petrol on a 56 plate with 70k milage and any help i would be grateful:speechless:
 

·
Registered
Joined
·
2,028 Posts
I think I'd start with checking and cleaning the battery connections. High resistance from corrosion/poor contact can cause all manner of nonsense.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
I think I'd start with checking and cleaning the battery connections. High resistance from corrosion/poor contact can cause all manner of nonsense.
Thanks Halftone yeah done all the usual cleaning and new battery in fact a more powerful battery i just thought on the process of elimination someone had previous experiences of my fault
 
1 - 3 of 3 Posts
Top