Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
does alfadiag show actual faults or just fault codes that you need to take the car to the dealer because they are manufacturer specific codes like for example cd142 (just made this one up )that doesnt give you a flamin clue to whats wrong with the car
 

·
Registered
Joined
·
397 Posts
I'm using it now. Excellent and clear descriptions of faults, in so far as the information from the sensors allows. So, it gives you the code, and a technical description, but no elaboration of the facts, since that can only be done with some human judgement.

But very good software. Be aware though, it can take some work to install various drivers on your PC to recognise the interface cable and other issues. Worth it though.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
thanks man ive already purchased the blue light interface for alfadiag just waiting for it to arrive the elm 327 doesnt work apparentely.
 

·
Registered
Joined
·
30,074 Posts
thanks man ive already purchased the blue light interface for alfadiag just waiting for it to arrive the elm 327 doesnt work apparentely.
ELM won't work with AlfaDiag.
But for a 147 (which has CANBus) you really want an ELM interface and FiatECUScan instead.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
I dont know really myself for a fact, but some people are saying that ecuscan is better and as a matter of fact if this alfadiag mob dont give me a product keysoon , so i can use it im gettin a refund from paypal and ill get ecuscan,I cant beleive its already been 4 days im waiting for this alfadiag , is it possible theyre just so busy they cant reply to emails .
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
all sorted it turns out my email spam filter was blocking alfa diag response turned it off and its all working now after debuugging the timout in the device config box its fantabulous,its a great peice of work, i'm a novice and im checkin pump pressures in the sensors section getting fault codes i love it,now i'm going to try and fix the bloomin 147pump relay problem???
 
1 - 7 of 7 Posts
Top