Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,
I am new to this site. Just bought an Alfa 166 Super 3.0 v6 which I absolutely love.
It has 100,000 miles on the clock but is so clean inside and out!
I have a few questions though that I hope you might be able to help me with?
I noticed a sort of burning smell when the engine is revved high say through second and third gears. I dont hold the engine for long at high revs but revving higher up through the gears seems to cause this smell!!! It does'nt smell like clutch burn and the engine temperature looks fine! Engine is smooth and responsive too! Can anyone help me with this?? Any ideas?
The other is regarding the clutch. I noticed if accelarating hard from 1st to 2nd gear the clutch does slip a bit when second is engaged and the power is put back on! Does this mean worn clutch?? It does'nt slip otherwise and bites quite low down. Any advice or help would be great!! Thanks.:)
 

·
Registered
Joined
·
1,567 Posts
..also check for any fluid leaks. Something may be leaking onto a hot part of the engine or exhaust, maybe power steering fluid..?
 

·
Registered
Joined
·
741 Posts

·
Registered
Joined
·
98 Posts
+1 on the clutch. I had the same issue with my clutch, my biting point was also very low before the clutch change. You might not need a new flywheel but it may be worth it in the long run to replace it with a solid flywheel from a GTV or GTA model as the dualmass flywheel in the 166 have been known to wear out quite quickly. You should be able to tell if its worn if the engine trembles/vibrates when in reverse.
 
1 - 5 of 5 Posts
Top