Alfa Romeo Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
can anyone help with this or experienced a similar problem, i switch indicator stalk in car, the indicators work but the little indicator lights on the dash next to clocks dont flash????? i have also noticed that when i indicate to the right the hazard button flashes, can any one help please:confused:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
thanks for that youve helped me bigtime, cheers, will let u know outcome but problem sounds exactly the same as yours, hopefully relay is the fault:thumbs:
 

·
Registered
Joined
·
129 Posts
Youre welcome! I´m sure a new relay or a refurbished one will solve your problems. Dont forget to put a plastic sheet to cover the electronic stuff located there from further damage by the leaking coolant!
 

·
Registered
Joined
·
9 Posts
Indicator Lights on Dash not working

can anyone help with this or experienced a similar problem, i switch indicator stalk in car, the indicators work but the little indicator lights on the dash next to clocks dont flash????? i have also noticed that when i indicate to the right the hazard button flashes, can any one help please:confused:

have the same Problem and like to save anyone extra money and effort.
I changed Bulbs,changed Relay under Driverside and Stalk.No good.
But as Quoted by other Members I will change the Relay under the Passenger Side Panel,
Fingers crossed

thanks to all members.This is a great Site
 

·
Registered
Joined
·
9 Posts
have same problem for last 2 year. it start sudenly with white smoke from dash, and indicators on dash died. only when turn on right indicator, red hazard lamp flash...
 

·
Registered
Joined
·
5 Posts
Had the same problem - although mine started after i got it back from the MOT - wasn't happy. Has anyone had success with this - if so, can you share what you replaced and where you got it?
 

·
Registered
Joined
·
42 Posts
Hi Guys,

Thought I would try and help you with this as I had exactly the same problem on my 166 which failed the MOT because no indicators lit on the dash (though working perfectly on the outside).

After a process of elimination decided that it must be the relay at the back of the ICS. The part numbers on the relay are "B883" and "60617164".

Found that the heater matrix had leaked directly onto the relay and fried it! So I sourced another relay (Alfa want £80 by the way :wow:) and fitted that, while I had the entre console side panels off in the footwells decided to cover all relays with polythene so if it ever leaked again it would just run off harmlessly. :) (By the way, the heater matrix dripping is a common fault on the 166 and if you have the Sportronic box be very aware - if it drops on the ECU relay then you can pretty much say goodbye to the gearbox!!! :rant::rant:)

Anyway as an extra precaution I used K-Seal product in the cooling system to ensure no future leaks - this has been recommended by a number of people on the forum, do a search!

Result - sorted the indicators and car sailed through the MOT. :thumbs::thumbs:

HTH :D:D
 

·
Registered
Joined
·
2 Posts
Indicators fault on dash

Hi,
had just discovered the same fault.
Smoke in the cabin:(
The relay, as you guys are talking about, is burned caused by small leak of coolwater from the heater matrix.
Does any of you guys know where the most common leak is? is it hose connections or the heater itself?
Do you have good experience with just using the K-Seal.........
Which will be much easyer than heater shift ;)

Thank you for a great and most helpfull site
 

·
Registered
Joined
·
1,800 Posts
It's the matrix itself that leaks so you'll have to replace this part. It's labour intensive but achievable - many of the guys on here have done it themselves.

Good luck!
 

·
Registered
Joined
·
248 Posts
Yep, the heater matrix seems to be pretty much guarantee fail at some point with the 166. If your lucky you can catch it early and k Seal is a good long term fix. I smelled coolant through my heaters on start up and used k Seal. If your unlucky, a whole host of electrical gremlins will surface culminating in loss of the ICS.
 
1 - 20 of 25 Posts
Top