Alfa Romeo Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I had a meltdown in my old Aircon compressor. The spades were litterally falling out of the bearings and it was grinding like crazy. Since I do not have the proper tools and machines to refill and flush i had decided to have the aircon compressor replaced by a garage. I bought a new compressor, a new dryer and had them replaced and refilled. Now afer this replacement the new pump would not engage. Before the old aircon compressor grinded itself down it was properly cooling and working. I assumed the problem was purely a mechanical matter. However the fuse that engages the compressor was fried as well so I replaced that. But now the mystery starts. The fuse did its work and was blown out but it is still not engaging after replacement. Now I tried to check the A'/C compressor relai but the relai cover itself is covered by a metal plate that goes all around it. It is the fuse/relaibox that is placed in the left side nose of the car just behind the left headlight. I find no way to remove the cover so I can acces the relais. Even though there is a screw to loosen up the cover. its just build in too far under the metal plate. it is the numer one most stupid thing I have seen so far.. Now I can be sure the engineers who designed this car were drunk and sadistic assholes.. However.. I am hoping someone knows how to get to the relais. Also i am very interested in other opinions about what could cause the compressor to still not engage.

Hope to hear from the experts what this could be.

Cheers.
 
1 - 1 of 1 Posts
Top