Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi, My Alfa 159 has just failed the MOT due to the front subframe having no resistance to a screwdriver attack. Could anyone please let me know what subframes are compatible with a ALFA ROMEO 159 JTDM LUSSO JTDM LUSSO ESTATE 2387cc (2006) DIESEL as there are loads of spider subframes on ebay but I do not know if they will fit. Many thanks in advance and sorry if this has been reported on before but I cannot find it being a newcomer.
 

·
Registered
Joined
·
2,834 Posts
Looking at the parts catalogue, it seems the 159 and spider subframe are a different part number, can't say I've seen a Spider subframe to compare to the 159.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Looking at the parts catalogue, it seems the 159 and spider subframe are a different part number, can't say I've seen a Spider subframe to compare to the 159.
Thanks for getting back to me, I did wonder if it was possible so unless it is just a minor bracket difference I will have to stick to the Lusso. Would size of engine also make a difference or were they clever enough to have just one size fits all?
 

·
Registered
Joined
·
3,437 Posts
Unless someone knows better I thought that all the front wheel drive Brera/159s, regardless of engine, had the same frame.....just the 4WD having a different frame. You wont have to stick to Lusso...that's just the trim level so does not affect the subframes.....but Im sure you knew that. Be interesting to know what's different on a Spider frame.....
 

·
Registered
Joined
·
2,834 Posts
I thought that also, only the subframe for the Q4 differed, I even typed a response to that extent but before I posted I thought I'd check, and the spider has a different p/n - the part drawing also looks different.

That's not to say the part isn't the same, but I'd be wary on that basis alone.

As @alfaitalia said, spec-wise makes no difference, a Lusso will share the same frame as a Ti.

Whereabouts are you based OP? You can buy a refurbed one from Autolusso, or contact Italia Auto Parts for a good used one.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
I thought that also, only the subframe for the Q4 differed, I even typed a response to that extent but before I posted I thought I'd check, and the spider has a different p/n - the part drawing also looks different.

That's not to say the part isn't the same, but I'd be wary on that basis alone.

As @alfaitalia said, spec-wise makes no difference, a Lusso will share the same frame as a Ti.

Whereabouts are you based OP? You can buy a refurbed one from Autolusso, or contact Italia Auto Parts for a good used one.
I am based at Ross on Wye, the dead centre of England (according to the map).
 

·
Registered
Joined
·
2,834 Posts
I've been there, it's rather nice - I particularly enjoyed the Man of Ross Inn.

Just thinking geographically where you might be able to get a 159 subframe locally, Italia Autoparts are the other side of Brum, according to his website he's breaking a 159 1.9 - don't know how up to date that is.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Hi All, thanks for all the help so far. I have managed to get a subframe from Leo who lives in Italy. However the car has been sitting in the drive, in gear, for 3 months and the battery was flat. I charged it and it would not even turn over. I attached a brand new battery and the usual screen comes on but as soon as I push the start button all goes black and a single click is heard in the engine bay. On removing the key fob and reinserting it the clock has reset to 0.00 and there is a warning that all aids are not working. Press start and all goes black again. Any ideas gratefully accepted.
M
 

·
Registered
Joined
·
2,834 Posts
Check your voltage, despite being a new battery, it might have been on the shelf a bit, next up check the earth points
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Check your voltage, despite being a new battery, it might have been on the shelf a bit, next up check the earth points
Thanks for the tip. It has sorted the problem and we are now awaiting the subframe with a car that runs. Fingers crossed it will then pass the MOT. M
 
1 - 15 of 15 Posts
Top