Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello. Got alfa 159 1.9Jtdm few weeks ago.
Done around 500miles, but before that car didn't have MOT for 6months, so it was just standing somewhere.

Gearbox broke, 4-5-6 gears missing... Okay... Changed the gearbox in a garage, after the job was done 8miles later lost power, as soon as the car reached 90 degrees.
Went straight to back to the garage, no one know what's wrong, they said drive it for couple hours and see.. another 2 miles later car doesn't start.
When disconnecting MAF car sometime starts for a second, and shuts off. Replaced MAF same, boost pressure regulator okay, EGR cleaned, Turbo working.
If the car starts and accelerating while standing still, takes around 20 seconds (not on gear) to reach 4000 revs. And a hell of a lot of white smoke coming out.
Computer not showing anything, until I disconnect something manually.
Anyone had anything similar?
Car is 2008, done 104k miles.
P.S.
Mechanics checked fuel rail pressure, all good. But the b*tch still doesn't start...

Any info appreciated very much.
Thanks!
 

·
Registered
Joined
·
259 Posts
White smoke could be a water leak, maybe headgasket blown?
Or just unburt diesel, does it have compression?
Injectors could be clogged up. Fuel pressure maybe low?
 

·
Registered
Joined
·
3,103 Posts
Map sensor being burned would lead me to think issue with EGR or clogging in manifold. I would take manifold off and have a good look as it could also have missing swirl flaps aswell that have caused damage to valves/turbo
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
All flaps were there. Manifold cleaned, flaps removed, holes isolated. Waiting for mechanics to asseble and test it.
 

·
Registered
Joined
·
3,103 Posts
That’s good then at least you know they ain’t been ingested. If no good after I would get them to compression test it
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
Manifold cleaned, flaps removed.. started for 5 seconds, and died again...
Will check cilinder pressure next...
This car is becoming pain in the ass...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
dont know. This car becoming huge money pit, it's not worth that much...
Anyone knows any good mechanic to diagnose in Boston area? My mechanic doesnt know what to do.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
Crankshaft sensor replaced, didnt help. Towed car home, and finally got error: Antipollution filter clogged.
Removed exhaust, started no problem, lots of smoke, kept it running for around 30mins and went for a drive, to make sure it gets unblocked fully, because revs came back to normal as well.
So 1-2 gear all good, 3rd gear lost power, fuuuukin huge cloud of smoke, stopped, didnt see anything, came back home (150metres), leaving oil trace all the way behind with hell of a lot of smoke..
Turbo blowed.. Replacing and dpf cleaning 320pounds... **** it! I'm selling it.
 

·
Registered
Joined
·
63 Posts
I feel your pain! My old SAAB gave me a few random troubles that took forever to diagnose.

So I bought my Alfa, and left the SAAB in the garage to worry about another day, hah!
 
1 - 19 of 19 Posts
Top