Alfa Romeo Forum banner
1 - 20 of 39 Posts

·
Registered
2019 Giulia Veloce
Joined
·
525 Posts
It really depends on what stereo you have. I decided to try and get BT music working rather than fiddling with USB but wanted to keep B&M for calls.

After a few items I bought which all didnt work(one of which like your example used the yellow connector) I bought this, which worked perfectly. Took 2 mins to install and now I can forget my USB music. Calls still work, steering controls work etc. Ideal!
https://www.amazon.co.uk/gp/product/B07CJKY1MR/ref=ppx_yo_dt_b_asin_image_o01_s00?ie=UTF8&psc=1

Now, it depends on your stereo. I have a 2012 159 TI with MP3 cd player and Blue and Me. (no bose, no nav and no cd changer). This cable uses the CD Changer functions, so as far as the stereo is concerned I have a cd changer now. If I press CD twice it switches to the bluetooth. My phone can connect to BlueMusic and BlueAndMe at the same time as they use different functions. One is media and one is calls.

//edit

Checked and my stereo is a Bosch Alfa 939 MP3.

Hope that helps.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
Hi, my bluemusic adaptor arrived today. Plugged it in but didn't work.
Could connect to the Bluetooth fine but cannot seem to select it as a source. On instructions it says press cd button twice, but doesn't seem to work.
Any ideas?
I have 2010 alfa 939 mp3 radio with Blue&me.
 

·
Registered
2019 Giulia Veloce
Joined
·
525 Posts
Hi, my bluemusic adaptor arrived today. Plugged it in but didn't work.
Could connect to the Bluetooth fine but cannot seem to select it as a source. On instructions it says press cd button twice, but doesn't seem to work.
Any ideas?
I have 2010 alfa 939 mp3 radio with Blue&me.
After plugging it in, did you get the option on your phone to pair with Blue Music?
If you press CD twice, it switches to the CD changer, which is actually your bluetooth. Which attachment did you buy, hopefully not the one with 2 unconnected wires.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #10 ·
All sorted. I'd left the power in when plugging in the adaptor. After unplugging the main power to the radio and plugging back in it worked straight away.
Thanks for you help.
I'm happy now! ?
 

·
Registered
Joined
·
26 Posts
Highly recommend this one
Damn Audio BTLINK
I looked into this, but it looks like they only sell this thing for the Alfa, and I cannot find any mention anywhere else in forums and such. And a single video dating to about two months ago. Do you have any info on this company? It's not that expensive so I would be happy to risk it, but I would still like to know that this is more than a website.
 

·
Registered
Joined
·
25 Posts
I looked into this, but it looks like they only sell this thing for the Alfa, and I cannot find any mention anywhere else in forums and such. And a single video dating to about two months ago. Do you have any info on this company? It's not that expensive so I would be happy to risk it, but I would still like to know that this is more than a website.
I've been using it for over 2 months now in my 159 with Bose system and I'm very satisfied with it. Previously I used Dension and it was a crap compared to this in terms of sound quality. I found them on YouTube, bought it directly from their website and received it in a week. I didn't notice anything suspicious.
 

·
Registered
Joined
·
1 Posts
All sorted. I'd left the power in when plugging in the adaptor. After unplugging the main power to the radio and plugging back in it worked straight away.
Thanks for you help.
I'm happy now! ?
Hello Hello,
Please I need your help because when I dont know what do you mean by "power" do you mean the power cable (the big connector behind the radio) or just the key contact before start the engine?

Thank you for your help :)
 

·
Registered
Joined
·
13 Posts
I went to Wilkinson's bought a 3.5mm jack lead for couple of quid cut one end off pulled stereo out spliced the wires into the yellow plug then put silent MP3 file onto memory stick works a treat, also I think you could buy a 2 into 1 USB adapter and 3.5mm to usb cable plug both into usb port with silent file on usb stick and should be good to go but haven't tried that one yet . Oh and don't forget to name the silent file (id3 tags) so the system can see it . Nice and easy and cheap
 

·
Registered
Joined
·
3 Posts
All sorted. I'd left the power in when plugging in the adaptor. After unplugging the main power to the radio and plugging back in it worked straight away.
Thanks for you help.
I'm happy now! ?
Hi, can you tell me if with your device the "phone" button on the steering wheelc can open and close the phone call?
Sorry for mi English, I'm from Italy.
I'd like to buy the version with the microphone for the music and calls too.
many thanks
 
1 - 20 of 39 Posts
Top