Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
Hi there. I recently purchased (another) 156 V6, this time, a veloce model. It is a 2003 model, with face lift interior. The car is a dream to drive, except for a couple of niggles!

Firstly, the dash is showing a light that I have a bulb out somewhere. Where, I haven't got a clue. Is there any way of clearing this???

And secondly, every now and again, the engine management light will come on, for no reason (other than to annoy me I think!), and can stay for a day, or a few days, sometimes even a week or so! But also goes without you even noticing too! Best bit is, there seems to be no disruption to my driving pleasure whatsoever!

Any feedback would be very welcome! Thanks.
 

·
Registered
Joined
·
30,081 Posts
Best way of fixing the bulb out warning is to replace the failed bulb...!
Have you checked all the bulbs, inc numberplate lights?

If not, you probably need a new rev-counter...... (it comes up a lot).


For the engine management light, you need it connected to diags to get a clue as to the cause.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #3
Cheers David. It is in now, and my mechanic says it is sometimes an earth problem with things. Just have to wait and see. Also, Would a fault show up on the diagnostics even if the engine management light isn't on???
 

·
Registered
Joined
·
30,081 Posts
Would a fault show up on the diagnostics even if the engine management light isn't on???
It should have logged a fault and it will say how many times the fault has occurred and if the fault is active when tested (which it probably isn't if the light is out).
 
1 - 4 of 4 Posts
Top