Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, excuse me for having this as my first post but I'd really like some experienced opinions on the issues with my car.

Recently bought a 156 Selespeed and everything was going smoothly, til about a week after when after stopping at some lights the gearbox flipped into neutral and refused to change gears.

After a short while the problem was gone, it would change gears again like it had before and then another week later it happened again.

Any tips or suggestions to help me at least have a clue what's going on? I want to take the car in to get checked out buuuut a recent string of bad luck has left me with not much cash for things that aren't bills.

Thank you!
 

·
Registered
Joined
·
846 Posts
You really need it on diagnostics to see what is going on with the system, quite frankly you are likely to spend more on randomly replacing parts without it. Good news is you can do it yourself for a few pounds.
Get a VK KKL cable off ebay (around £5-10), download the free version of Multi Ecu Scan http://www.multiecuscan.net/or whatever Alfadiag is now called and you can see what the sensors/system is doing.

Two things to bear in mind - if you leave the car in gear whilst stationary it will go into neutral after a couple of minutes and then you did remember to out your foot on the brake before trying to get it into gear ? You would be surprised how many new sele owners forget that bit :)

From the description you MAY have an intermittent selespeed pump/relay issue but as I say it rwally needs plugged in.
If you let us know your location some kind person might offer to plug the car into diagnostics for you !
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Aw no I didn't realise I hadn't put my location up. I live in Brisbane, Australia.

Thanks so much! I definitely do put my foot on the brake but I'll invest in getting that cable!
 

·
Registered
Joined
·
12 Posts
Does the selespeed warning light on the dash flash and beep too? I recently replaced the accumulator on my jts sele as it was dropping out of gear and sometimes stalling - i've done 1 week and 230 trouble free miles since so am hoping I may have solved my problem. The part cost £60 and i fitted it myself. It appears that leaky accumulators can give intermittent gear change problems that gradually become more frequent.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yeah it does, slips out of gear, the icon starts flashing and beeping and doesn't reset for about 1 minute.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
So I only just got my cables and plugged it in, have an error code for the gearbox P1772. Anyone know if that's the problem? Not really sure what i should be looking for here as I'm kinda new to all this and any help would be amazingly appreciated!
 
1 - 8 of 8 Posts
Top