Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, i recently bought my first ever alfa, a 2002 156 jts 2litre, for a song as it had some body damage and the dreaded " motor control failure" warning. I am having the cam belt etc done on weds by Auto Italiana in exeter as the mileage is 61000 and sidwells failed to change it at the last 44000 mile service. Anyway, i noticed the oil was rather dirty so decided to change the oil and give it a flush out. Once done i drove the car to get some petrol, when i started up the warning message had gone and , as yet, hasnt come back. So have i cured the fault by changing the oil? has anyone else done the same thing? also, what should the rumming temp be as it seems to flutter between 50 and 90 depending what driving im doing, maybe a new thermostat? be nice to hear from you lot, many thnaks lee
 

·
Registered
Joined
·
14 Posts
Dont think that could cure it, in my workplace we had a GT JTS which kept on bringing up motor control system failure for months took for ever to get to the bottom of it and that was on sim mileage as yours. Best thing to do it take it somewhere and get it plugged in and see what the trouble code is? if it says partial load mixture strength then i have the answer otherwise it could be more simple. If it says partial mixture strangth then it will need to have all the inlet manifold removed and cleaned up as it may have got clogged up, this is the problem that we had after trying everthing thin else, so might save you some money here but get it plugged in first when the light is on, it should have stored the fault code anyway.
And if it is not warming up properly then yer would be the thhermostat very common on alfas but around 90 is common, does it take a long time to warm up?
 

·
Registered
Joined
·
12,881 Posts
... does sound like you need a new stat ... the temp should sit pretty much at a solid 90 (+/- a few degs ...) ...


... With my MCSF I had it a for a few weeks on and off, then it went away (horray) ... for a few months anyway ... but now it's back :( ...
 
1 - 4 of 4 Posts
Top