Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hello i'm Samuele from Italy exactly near Florence.
My JTS (i'm first owner from may 2002) have a problem with warning light.
With examiner fault codes are p1172 (Lambda adaptat. 2 (additive) above upper limit ) and p1173 (P1173 Lambda adaptat. 1 (multiplicative)).
I feel car good no problem.
MAF seems good but is difficult to say. I have changed precat lambda for safety.
I have read the problem with lambda's connections so i have sprayed it.
This problem appears sometimes also when car was stock. Now have direct kn induction, then mainflod is 4-1 exausth, sport cat 200, sport rear exausth; all by cecam. I think that these thing are not important for my problem.
Possible solution?
I think MAF but i can't change a lot of thing without certainty.
Thanks for attention and sorry for my italian english :D
 

·
Registered
Joined
·
35 Posts
The most commom fault is the two top lambda sensors ( pre cat sensors ) if you have a look at the connections you will see there 6 pins to them, The mod we do is cut the connection of the wiring loom end and solder the wires straight to the sensors, tricky to do but that will fix it. Cleaning the connections wont last for long.

Dont leave this too long as it can damage your cat.
Also to check the two lower sensors which are 4 pin connections, you will have 2 white wires, 1 grey and 1 black, you will need a mulit meter to do this but what you do is check that the two white wires have resistances between them.... if it is an open circuit then that sensor is broken.

Hope this helps
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
Thanks a lot, so you think i must fix lamdas' connection to resolve warning light?
MAF in your opinion is good in my 156?
Best regards.
 

·
Registered
Joined
·
35 Posts
From the fault codes you have, in my experience it has always been those sensors, do the repair i siad above if you think you can or get a garage to do so.
 
1 - 7 of 7 Posts
Top