Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Well, i got the motor control system error warning appear about a month ago.

I have fiatscan and the right cable. I cleared the errors, without really jknowing what i was doing in fiatscan, i am sure they will come back though. so i can post them up here. The errors related to the fuel mixture.

From my limited knowledge I thought it must be the lambda sensor! I have now learned that there is two! Proving a modern injection/ecu system is abit more complicated than my single injector classic mini!

However i do have the live data, which hopefully someone can interpret:

Lambda 1 signal (pre-cat) - 0.440
Lambda signal 2 (pre -cat) - 0.445
Lambda 1 signal (after cat) - 0.460
Lambda signal 2 (after cat) - v (which i assume is no signal)

Lambda 1 status (pre-cat) -closed loop - all at full operating temp circa 90 degrees
Lambda 1 status (after-cat) - open loop
Lambda 2 Status (pre -cat) - closed loop
Lambda 2 Status (after -cat) - Open loop

when turned to the MAR position all status were closed, if that makes a difference!

All input appreciated, i would like to try and fix this myself, without a garage!

Many Thanks
 

·
Registered
Joined
·
2,904 Posts
Your lambda readings seem ok, I checked mine today and they show similar.

There's 3 sensors on the cf3 engine, 2 on the manifold and 1 post cat.

I have a recurring fault which shows lambda 2 no signal, but seems to work, this hasn't flagged the mcsf light, so assuming its a duff connection somewhere.

Your fault code suggests something else, if it recurs take a note of the number, should begin with a P
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Well as thought the MCSF fault popped round to say hi today!

Faults codes are -

P1177 - Mixture Correction (multiplicative)1
P1178 - Mixture 2 Strength (multiplicative)

Anyone any experience with these. All input greatly received.
'
Thanks so far amfalconer!
 

·
Registered
Joined
·
9,912 Posts
airflow meter fault ..ecu is mixed up with incorrect readings ..it throws a wobbler and just throws them codes ..you got fine lambdas ..make sure they are switching evenly
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Well 8 days and counting since i fitted a new MAF/airflow meter and the MCSF light is still off! Good times! Thanks guys!
 
1 - 6 of 6 Posts
Top