Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i recently puchased a 147 alfa non runner from a auction .
the motor was swinging but wouldnt start.
after numerous attemps to start it i eventualy took it to alfa mechanic.who informed me that the computer on the car was faulty.maybe due to someone trying to jump start the car.
and that he knew of someone that could repair it for me.
somehow my gutt feel tells me that.the mechanic is out to make himself a fast buck
is there anyone here that can tell me what are the symtoms of an alfa thats computer has bombed out?
 
N

·
Guest
Joined
·
0 Posts
Hi there.

Have a search in the technical section.
There are some threads on this. ;)
 

·
Registered
Joined
·
13,001 Posts
Welcome:)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
hahaha. good one mate..i guess im just as holy on my alfa`s.
gr8 collection u have there.
i must get down to posting a pic of mine. i own. a silver 156 sportwagon 2.5 v6. a red 3door 147 2l t.spark.under restoration.
and the "Terrible Twins. a silver 2l .t.spark spider.and a black Gtv..and contenplating on a buying 3l gtv.that was offered to me today.minus a front bumper...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
Hi All,
good news!! my 147 computer box problem sorted out..and the car is up and running. i am told the previous owner probably tried jump starting it. and blew a few components..on the computer...
hmmm..i wonder..how true this diagnose is..
i know another guy who was told a similar story..that his GTV`s computer was faulty and that he would have to have it recoded...
an auto elec.had a look and found a bad earth on the car..he was a lot more fortunate than me.. and a lot less out of pocket..
 
1 - 14 of 14 Posts
Top