Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm wondering how I can attach my HTC desire HD to the radio to play my MP3's & also have a hands free setup. I've looked around for the usb connection in the glove box but can't seem to find anything so could any help please. I have an Alfa GT 1.9 JTD Bertone
I thought the Bertone would have all this as standard spec
This is not the only issue with a car I have only had for a month
The Cruise control does not work & has never worked since I bought it
There is a diesel or oil leak form the drives side just in front of the wheel it's only a spot at the moment.
The back parcel shelf squeaks & is driving me crazy
There is a error that comes up on the dash rear fog light issue but the fog lights come on when switched & the error goes away for a while then shes back again.
thinking of calling her the Grinch as she is trying to spoil xmas.
There are a few other issue but thats enough for now
Any help on one or all of these issues would be kindly appreciated.
 

·
Registered
Joined
·
2,429 Posts
I'm wondering how I can attach my HTC desire HD to the radio to play my MP3's & also have a hands free setup. I've looked around for the usb connection in the glove box but can't seem to find anything so could any help please. I have an Alfa GT 1.9 JTD Bertone
Is this a relatively new car? I didn't think any GT came with a USB connection. I'd say your best bet is to get a Parrot kit fitted - or else change the headunit.

Come to think of it, is there such a spec as 'Bertone' for the GT? Bertone was the designer and all GTs have a 'Bertone' badge on the side of the car - that has nothing to do with the spec.

The Cruise control does not work & has never worked since I bought it
Usually due to an issue with the switch on the clutch pedal - see if you can have a look yourself, but it should be a simple fix either way.

There is a diesel or oil leak form the drives side just in front of the wheel it's only a spot at the moment.
Could be an issue with the hose going the oil cooler. Get it checked out ASAP.

The back parcel shelf squeaks & is driving me crazy
Have a search - there's plenty of discussion on this matter on this forum.

There is a error that comes up on the dash rear fog light issue but the fog lights come on when switched & the error goes away for a while then shes back again.
That is a pain, see if a bulb is loose, or maybe a connection.
 

·
Registered
Joined
·
2,900 Posts
The clutch switch may have been pushed in too far owing to a clutch pin failure, it's a white switch, which you quarter turn to remove. get a pair of pliers on the moving part of the switch and give it a good pull, it should eventually come out with a ratcheting noise.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Cheers for the help have read a few threads on the squeeky parcel shelf, tried a few of the ides but know real improvement, took out Clutch switch ,There is nothing wrong with the clutch switch it is fully extended but still does not reach the clutch bracket when the pedal is fully extented (not pushed down)
 

·
Registered
Joined
·
10 Posts
Before mine got fixed under warranty, I just blu-tacked a couple of 1p pieces to the flat bit that pushes the switch, hey presto, working CC!

As for the squeaks, check the boot struts for wobbling left and right (the metal hinges) as they can sometimes go, and also the boot release gas pushes, I've been advised to push these in (so they are fully in) and give them a turn which stopped a rattle from the back of mine...

Also check the tools and spare to make sure they aren't rattling about.

Alternatively, turn the stereo up nice and LOUD :)
 
1 - 6 of 6 Posts
Top