Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
44,882 Posts
Discussion Starter #1
I did about 400 miles yesterday, mostly motorways with a few minor traffic jams. All seemed well, car behaved itself. Went out this morning to check it was alright and found it had used more than 50% of the oil ! :eek: I checked yesterday morning before starting off and it was about 90% up the dip stick, checked again this morning and it was a maximum of 20% up the dip stick. God knows what would have happened if I'd gone the long way round !
 

·
Registered
Joined
·
389 Posts
The car is parked flat right?

If its lost that much while sitting on your drive and the car is flat then there will be a puddle of oil under the car as the 95s dont have an undertray.
 

·
Registered
Joined
·
44,882 Posts
Discussion Starter #3
Parked on a flat surface, no puddle underneath. Used all this oil yesterday while driving around. Excessive even for an Alfa ! :lol:
 

·
Registered
Joined
·
174 Posts
check when cold. take dipstick out and wipe down length . reinsert and rotate it , draw out and examine it horizontally...should see the oil in flat section which is only about 1 cm!
 

·
Registered
Joined
·
44,882 Posts
Discussion Starter #7
sump washer ok?? when last serviced?
Serviced last October, no obvious oil leakage.

check when cold. take dipstick out and wipe down length . reinsert and rotate it , draw out and examine it horizontally...should see the oil in flat section which is only about 1 cm!
I tested it about 5 times this morning, couldn't believe it, thought I had not put the dipstick in properly.

maybe start it and look at exhaust for blue smoke and obvious oily smell... mileage of car?
No blue smoke, no oily smell, only done 31000. It does use oil if stuck in heavy traffic but not this bad.
 

·
Registered
Joined
·
389 Posts
I think its bout 0.5l from max to min on the dip stick, mine uses about that every 10-15000 miles. The total is only 3l so theres not that much in the engine anyway on the 95s.

Has it not been driven for a while? When did you last check the oil?

Is it blowing out of the top somewhere under the plastic engine cover, eg around the plugs?
 

·
Registered
Joined
·
44,882 Posts
Discussion Starter #12
It was sat idle for a few days before but that has never been an issue before. I check the oil every week or after a long journey, I thought it was overkill but now I'm glad I do check so often ! The engine bay looks clean, if it was blowing from somewhere I'm pretty sure I'd spot it.

Could it have something to do with moving slowly in 1st or 2nd gear for long periods ?

It is going in to the garage to be checked next week, can't live with the uncertainty !
 

·
Registered
Joined
·
1,734 Posts
I'm just after buying another 5 liter oil top up for a 1.6 TS.
I know its low when cornering I got an oil warning.
It bleeped today for oil and petrol:lol:
 

·
Registered
Joined
·
44,882 Posts
Discussion Starter #15
Been in the garage today, they said they could find nothing wrong! :eek:

They thought I might have got a false reading before setting off and the oil level was lower than I thought from the start.
 
1 - 17 of 17 Posts
Top