Alfa Romeo Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
I have the airbag light on my dash. It is the little red man with the ballon.


It stays on from start up.


I have been under my seat and unpulgged and replugged the connections.


Light still on.


Does anyone know how to reset the light or disable the airbag please?


I have my MOT very soon, and want to get the light switched off


THANK YOU
 

·
Registered
Joined
·
37,151 Posts
The car won't fail the MOT on the airbag light.

To reset it you need an OBD2 cable with pins 3 and 7 shorted together, a laptop and either unidiag or Alfadiag.

Or you could get a garage to do it, but that will cost you.

Unidiag is free and you can get cables ready madeup from Rarebear for around £35
 

·
Registered
Joined
·
1,752 Posts
The only way is to use a software system - either through a dealer or indy using Examiner or a forum user who has Alfadiag or another software system. Airbags are not supposed to be fixable by the general public because they contain explosives and are therefore deemed a danger
 

·
Registered
Joined
·
7,032 Posts
if you were in the neighbourhood of Rijswijk (holland) I would do it for a beer !!! (did that many times hick)
but better buy the cable and a license for Alfadiag, it will save you a bundle !!!
 

·
Banned
Joined
·
9,721 Posts
if you were in the neighbourhood of Rijswijk (holland) I would do it for a beer !!! (did that many times hick)
but better buy the cable and a license for Alfadiag, it will save you a bundle !!!
Darn, I used to go diving in the lake there and the one down at Rotterdam harbour about 30 minutes away.
 

·
Registered
Joined
·
7,032 Posts
Darn, I used to go diving in the lake there and the one down at Rotterdam harbour about 30 minutes away.
well I'll be d*mned !!! I did dive that lake as well !! but mostly in Zeeland
Oosterschelde and Grevelingen.. but I rather dive the Red sea and Caribean now !
did some great diving in Tenby (Wales) on a wreck... got me a porthole !! and we sawed off the propellor... it was vacation ! but I spent hours on the bottom of Bristol channell
sawing away !!!:p
 

·
Registered
Joined
·
7,032 Posts
just another warning : reset with AD will not always work, if the crash sensor is broken or the clockspring or the sensor pad in the passenger seat !! but in 99% of all cases I handled the red light was caused by a bad connection so resettable.
 

·
Registered
Joined
·
37,151 Posts
I couldn't get my airbag ECU to respond to either Alfadiag or unidiag, let alone attempt to reset it.

I tried a different Airbag ECU and I got the same problem.

It looks like there is a problem with the power supply to the ECU, but I haven't had chance to check everything out to find out for sure.

Tis very annoying. :(
 

·
Registered
Joined
·
37,151 Posts
The one that you sent me. :)

I might try it on the Fiat bravo later to see if it works on that.

The Bravo doesn't have the airbag light on though, but I still should be able to access the ECU.
 

·
Registered
Joined
·
1,752 Posts
If you get anywhere near Canary Wharf or Biggleswade I would be happy to have a go - I have also got a cable from Rarebear and have been able to fix my airbag light and another forum users
 

·
Registered
Joined
·
7,032 Posts
The one that you sent me. :)

I might try it on the Fiat bravo later to see if it works on that.

The Bravo doesn't have the airbag light on though, but I still should be able to access the ECU.
:) I tested that cable on my 156 (also airbag !) before sending... but if it packed up
I'll send another !!! warranty is my middle name :cool:
 

·
Registered
Joined
·
96 Posts
Yesterday my airbag light came on. Did all the usual things under the seat etc. no joy. I called the rac who then connected there all singing and dancing PC. did A full reset and all is good. The guy did point out though that he is aware that the child's airbag switch near the glovebox can cause this error to occur. H eased that this can be cured by removing the lining on the glovebox to get to the switch, (must be done with the ignition off at all times.) then remove the plug at the back and clean with wd40 then put it on then remove it. Do this several times then put it all back together. This fixes the problem once the airbag light has been reset.. All I this service was free! And all fixed within 90 mins of calling. Excellent service!
 
1 - 20 of 28 Posts
Top