Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
LOL you gotta love alfas just spent the best part of £1000 on cambelt and service + tyres and my airbag light has come on.

I know the fault could possibly be connectors under the passenger seat but what i need to know is will the Airbag still work with the warning light on? Also i heard a rumour that leaving the battery disconnected over night will turn it off, Fact or Fiction?
 

·
Registered
Joined
·
4 Posts
No man, i also have the same problem. i just reset it. Also enquired if we can mount the sensor some where else. but no luck LOL. i suggest you make freiends with the service guys so that he can reset for free.
 

·
Registered
Joined
·
485 Posts
Not worth the risk - get it sorted. For peace of mind if anything else, I feel much safer now without the airbag light on.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #7
may i ask where the plug is?

I have looked under the front passenger seat and can only see a loom covered with black plastic, is there a plug under there?
 

·
Registered
Joined
·
2,133 Posts
may i ask where the plug is?

I have looked under the front passenger seat and can only see a loom covered with black plastic, is there a plug under there?
The yellow cable underneath the seats is the airbag cable. The black is for electric seats.
 

·
Registered
Joined
·
1,109 Posts
may i ask where the plug is?

I have looked under the front passenger seat and can only see a loom covered with black plastic, is there a plug under there?
yeah were the hell is this mystery plug?????????:cry:
 

·
Registered
Joined
·
30,171 Posts
On my 156 it is in a plastic box under the front edge of the seat.
 

·
Registered
Joined
·
7,032 Posts
you need a small investment for Alfadiag and a lead, and you can wave your hand to the dealer !
 
1 - 13 of 13 Posts
Top