Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,

The air con in my 2003 V6 156 is not getting cold, I have had it checked, it has full pressure.

But the tech said that it was only getting down to 10 C and it should be able to get down to at least 5 C.

It seems to have less air flow to the vents on the driver side, than on the passenger side.

The air also feels a little colder from the passenger side vents than it does from the driver side vents.

Any thoughts would be greatly appreciated. Next step looks like it willl be to the local Alfa dealer, to have the full system checked.

With regards

Worlord
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Hi,

Thanks for responding.

I'm not sure how long the pollen filter has been in the car, I've looked through the service history and can not see any mention of it being serviced or replaced.

Is this something that I can replace or do I need to take it to Alfa service or an air con tech.

Regards

Worlord
 
0

·
Guest
Joined
·
0 Posts
DIY job, I assume yours is the facelift, so will be in two parts under the dashboard on the passenger side
 

·
Registered
Joined
·
30,246 Posts
Still don't think you will get it down to 5degC though.
 
0

·
Guest
Joined
·
0 Posts
I read about someone replacing their pollen filter & it making a 'significant' difference to the temperature - no measurements taken though
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Hi,

Thanks for that; I'll check it out in the morning.

Do I have to replace it or is it able to be cleaned and put back

Would this also be causing the lack of air flow throiugh the vents or is that a separate issue.

Regards

Worlord
 

·
Registered
Joined
·
30,246 Posts
You replace the filters.
Yes a dirty blocked filter will restrict airflow.
 
1 - 9 of 9 Posts
Top