Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,484 Posts
Discussion Starter #1
hi all,

recently been somewhat on the warm side so decided to switch on the air con after not much action since regassing it last spetember...
well...no discernible difference!
is this normal?....my spider's air con has never been used much since i got it, but the output is non existant....

am taking it for a looky this week anyway...
 
J

·
Guest
Joined
·
0 Posts
i would guess that it is not working properly.....

easy way to tell, engine running, switch the aircon on, look at the aircon compressor, is the centre of the pulley spinning, if it is then it is working, if not then it isn't....

it could be not working for something as silly as being slightly below the required level of refrigerant
 

·
Registered
Joined
·
1,484 Posts
Discussion Starter #3
thanks Jas....i hope its somethin as simple as that...taking it up to the workshop for a check up this week anyway...
just wondering if anyone else had experienced the same or knew what it may be specifically
 

·
Registered
Joined
·
469 Posts
Mine used to do nothing ... had it regassed as part of the service at Autolusso and it's great since.

Mind you, I almost never use it as I'd rather put the roof down!
 

·
Registered
Joined
·
3,336 Posts
As with all a/c systems, if not used, seals will dry out and the refrigerant will be lost. If not too far gone, a re-charge will often help re-lubricate and rejuvenate seals, and things will be fine for years afterwards.

Get it checked at a proper a/c specialist, places like Kwik-Fit don't really know what they are talking about...
 
A

·
Guest
Joined
·
0 Posts
Jumping on this thread - when i start the car and turn the AC on the light flashes on the button for a while. You hear the compressor kick in and the light stops flashing. Compressor doesnt seem to stay on though. Keeps switching on and off - more off than on. Any ideas anyone? Also makes a bit of a whining noise at times.

Cheers
 

·
Registered
Joined
·
469 Posts
The flashing is an error code. I've seen a list of these somewhere - can't remember if it was in the Owners' Handbook or the Workshop Manual tho.
 

·
Registered
Joined
·
27 Posts
Jumping on this thread - when i start the car and turn the AC on the light flashes on the button for a while. You hear the compressor kick in and the light stops flashing. Compressor doesnt seem to stay on though. Keeps switching on and off - more off than on. Any ideas anyone? Also makes a bit of a whining noise at times.

Cheers
Sounds like my wife, and nothing can be done with her! :cheese:
 

·
Registered
Joined
·
11 Posts
one of the easiest ways of checking the aircon is to take a thermometer check the outside temperature then switch the aircon on with the engine running, switch to the centre vents (close other vents) turn the fans on to number 2 and put the thermometer to the centre vents (in the vents if poss) also switch to recirc. the reading should not be more than a quarter of the outside temperature. ie if you have 20deg outside then you should look for around 5deg at the vents.
 

·
Registered
Joined
·
469 Posts
Just checked the Workshop Manual - if the a/c light flashes then it's indicating an error condition. To find the error you need to connect something that can read the ECU diagnostics.

Not sure if Alfadiag/Unidiag can read a/c errors - might need the original Alfa "Examiner" tool that only Alfa specialists will have.
 
A

·
Guest
Joined
·
0 Posts
Flashing continued today - followed by a fairly bad noise from the compressor. Sounds like a failed bearing or something briefly - then switches off. :(
 

·
Registered
Joined
·
469 Posts
I'd take it to an Alfa specialist and get them to hook up their diagnostic kit. I'd expect them to do this for free, as they'll be hoping to get your business to fix it!
 
1 - 13 of 13 Posts
Top