Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys,

Still getting this GTV upto spec... The air blower only works on setting 4 and the aircon doesn't get cold but this is probably a seperate issue. The question is does the blower have some kind of electronic regulator to control the speed of the fan and if so where is it?

Cheers

Dave
 

·
Registered
Joined
·
1,807 Posts
Sorry, bit out of my depth. On my '99 V6 the blower speed settings are 0.....4 and AUTO. Only on AUTO does it have a mind of its own. I suppose that could be when it's not broke though!
 

·
Registered
Joined
·
6,351 Posts
Here goes-- if you look in the passenger footwell upwards under/behind the glove box you will see the heater motor blower. To one side of the housing there is a rectangular, with rounded ends, device and according to the manual this is either the fan resistance or electronic variator control for the motor. I presume the former is for non air con or climate control and the latter is for one with air con or climate control but I have no direct experience, I'm just going by the manual. It appears that the resistance device has more connecting wires than the electronic device.
 

·
Registered
Joined
·
2,917 Posts
Here goes-- if you look in the passenger footwell upwards under/behind the glove box you will see the heater motor blower. To one side of the housing there is a rectangular, with rounded ends, device and according to the manual this is either the fan resistance or electronic variator control for the motor. I presume the former is for non air con or climate control and the latter is for one with air con or climate control but I have no direct experience, I'm just going by the manual. It appears that the resistance device has more connecting wires than the electronic device.
8..
7..
"Cut the blue wire..... no wait the red wire!"

"The countdown just increased"

4..3..2..1.. Kaboom!



Sorry can't help either but just wanted to add a bit of drama to the proceedings
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks for that Armoore I will have a look at the weekend in the daylight....by the way Monty if I cut the red wire and the countdown does increase, I may not be making any further contact!!
 

·
Registered
Joined
·
6,351 Posts
When I first started teaching many years ago the caretaker of the school was an ex-sapper who was in bomb disposal just after WWII, I had the greatest of regard for him!
 
R

·
Guest
Joined
·
0 Posts
You're on the right track, thermal resistor I think they call it. It will need replacing probably. setting four is when you have full power to the fan (ie no resistance) all other settings go through this resistor hence why it will work on no. 4 and nothing else.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
Whilst I was doing the job of replacing the resistor I had to replace part of the loom as it had burnt out. I also took the control switch in the dash apart "be careful springs and ball bearings inside" there is a carrier with a contact point that is suspended on a spring, on mine this was stuck in the "In" possition so wasn't making contact properly at any setting try that before the resistor if the resistor shows no signs of burnout. As Monty says it is under the passenger side dash located just above the level of the passengers feet and is grass green and oval in shape it has two screws holding it in possition and is a pig to get to, it has a three wire conector block and the resistor its self is open to the elements for cooling inside the air box. I hope this helps someone!
 
1 - 14 of 14 Posts
Top