Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5,621 Posts
Discussion Starter #1
has anyone else had an issue with the air filter box moving around slightly and knocking inside the engine bay when going over bumps etc, if so how did you resolve this i was thinking of just putting something on the side of the box to cusion it?
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #2
well it's definatly that knocking, i've jammed a small piece off wood there for now as a temporary fix, until can find somethin a little more permanant
 
S

·
Guest
Joined
·
0 Posts
Can you explain it a little but more? Like is there a bracket that is broken of something like that??
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #4
no nothing broken, just where the main air box sits it keeps knocking agains the metal frame right next to where the box sits
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #6
have to have a look, don't think there's anywhere to put a cable tie trhough on the box, tho
 

·
Registered
Joined
·
30,243 Posts
There are pegs in the base of the airbox that should locate in holes in the baseplate below it. Those holes should have rubber grommets to make the pegs a tight fit.
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #8
There are pegs in the base of the airbox that should locate in holes in the baseplate below it. Those holes should have rubber grommets to make the pegs a tight fit.
ahhhh i didn't know that will have a closer look tomorrow then, i remember seeing the rubber bits they must have just popped out
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #9
turns out the little feet which slot into the holes under the box have broken off, is there any other way i could maybe secure it or am i gonna have to replace the box
 

·
Registered
Joined
·
8,063 Posts
I think it must be unusual for the feet to have broken off since there isnt much force on them. To replace the box would be quite expensive for such a small thing, maybe you could simply tie-wrap it to the bottom mount instead of using the feet.

The feet on my airbox dont fit into those holes because I've moved it over a few inches to give clearance for bigger air intake pipe but the way I have it fitted it doesnt move at all.
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #11
does anyone know where i can get a replacement clip for the hose which goes up from the air box and connects into the pipe where the sensor is, the pipe has the clip where it meets the air box but i need a replacement clip for the other end (where it meets the sensor)
 

·
Registered
Joined
·
5,621 Posts
Discussion Starter #12
I think it must be unusual for the feet to have broken off since there isnt much force on them. To replace the box would be quite expensive for such a small thing, maybe you could simply tie-wrap it to the bottom mount instead of using the feet
yeah i was thinking along those lines too, it must have happened a few weeks ago, i had a little dink with a wall in the snow, it broke the curved pipe and the little box behind the bumper but thought it had caused no other damage i replaced that box and pipework with a used one i was lucky enough to find on the bay.
 
1 - 12 of 12 Posts
Top